summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-21 13:18:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-21 18:51:35 +0200
commit25c17538a7319110c9b866f656af614a003b64a4 (patch)
treeffecd07489d31ce3799da76e40691bd19d5d14a7 /dev-python/fusil/fusil-1.5-r1.ebuild
parentapp-editors/ng: clean up old. (diff)
downloadgentoo-25c17538a7319110c9b866f656af614a003b64a4.tar.gz
gentoo-25c17538a7319110c9b866f656af614a003b64a4.tar.bz2
gentoo-25c17538a7319110c9b866f656af614a003b64a4.zip
dev-python/fusil: EAPI 6 bump.
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/fusil/fusil-1.5-r1.ebuild')
-rw-r--r--dev-python/fusil/fusil-1.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/fusil/fusil-1.5-r1.ebuild b/dev-python/fusil/fusil-1.5-r1.ebuild
new file mode 100644
index 000000000000..dc4064523370
--- /dev/null
+++ b/dev-python/fusil/fusil-1.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1 user
+
+DESCRIPTION="Python library to write fuzzing programs"
+HOMEPAGE="https://bitbucket.org/haypo/fusil/wiki/Home https://pypi.python.org/pypi/fusil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/python-ptrace-0.7[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C doc RST2HTML="rst2html.py"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 -1 -1 "${PN}"
+}