summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-07 09:24:22 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-07 09:56:19 +0100
commitaeabd4aedf751af3ca50f84b4e76ae8361f966bd (patch)
tree40a9d763d7e378a749a0160c2247579f8af6f5a0 /dev-python/genty/genty-1.3.0.ebuild
parentdev-python/hypothesis: Version Bump (diff)
downloadgentoo-aeabd4aedf751af3ca50f84b4e76ae8361f966bd.tar.gz
gentoo-aeabd4aedf751af3ca50f84b4e76ae8361f966bd.tar.bz2
gentoo-aeabd4aedf751af3ca50f84b4e76ae8361f966bd.zip
dev-python/genty: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/genty/genty-1.3.0.ebuild')
-rw-r--r--dev-python/genty/genty-1.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/genty/genty-1.3.0.ebuild b/dev-python/genty/genty-1.3.0.ebuild
new file mode 100644
index 000000000000..3b83b4580fca
--- /dev/null
+++ b/dev-python/genty/genty-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows you to run a test with multiple data sets"
+HOMEPAGE="https://pypi.python.org/pypi/genty https://github.com/box/genty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+# https://github.com/box/genty/issues/42
+RESTRICT=test
+
+python_test() {
+ esetup.py test --verbose
+}