summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/ghp-import
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/ghp-import')
-rw-r--r--dev-python/ghp-import/Manifest1
-rw-r--r--dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild33
-rw-r--r--dev-python/ghp-import/ghp-import-0.4.1.ebuild20
-rw-r--r--dev-python/ghp-import/metadata.xml14
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/ghp-import/Manifest b/dev-python/ghp-import/Manifest
new file mode 100644
index 000000000000..7998fca49546
--- /dev/null
+++ b/dev-python/ghp-import/Manifest
@@ -0,0 +1 @@
+DIST ghp-import-0.4.1.tar.gz 5002 SHA256 6058810e1c46dd3b5b1eee87e203bdfbd566e10cfc77566edda7aa4dbf6a3053 SHA512 8b0e6578f05dc74449082a840ccd609a43fba3ca1c4dffacaddc4b27d2e9e3eac565a5c9672734e6ec5f2e8872b13ae0bb8a5d6bae4ee6c4cf41ef7d2c0b2eda WHIRLPOOL 15008edc2539affef67267859ce3a4019e1d3621e8e0a2cb3b74de53af2fb5433f77a74b1742552ccc223fdc9cc30db135a0b9f0cd796ce2df38bfc83c7aa24d
diff --git a/dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild b/dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..125ee3a27796
--- /dev/null
+++ b/dev-python/ghp-import/ghp-import-0.4.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy your docs directly to the gh-pages branch"
+HOMEPAGE="http://github.com/davisp/ghp-import"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="tumbolia"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ ebegin 'patching setup.py'
+ sed \
+ -e '4ifrom codecs import open\n' \
+ -e '/LONG_DESC/s/))/), encoding = "utf-8")/' \
+ -i setup.py
+ STATUS=${?}
+ eend ${STATUS}
+ [[ ${STATUS} -gt 0 ]] && die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/ghp-import/ghp-import-0.4.1.ebuild b/dev-python/ghp-import/ghp-import-0.4.1.ebuild
new file mode 100644
index 000000000000..495438c355bb
--- /dev/null
+++ b/dev-python/ghp-import/ghp-import-0.4.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Copy your docs directly to the gh-pages branch"
+HOMEPAGE="http://github.com/davisp/ghp-import"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="tumbolia"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
diff --git a/dev-python/ghp-import/metadata.xml b/dev-python/ghp-import/metadata.xml
new file mode 100644
index 000000000000..7b9245a12d88
--- /dev/null
+++ b/dev-python/ghp-import/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">ghp-import</remote-id>
+ <remote-id type="github">davisp/ghp-import</remote-id>
+ </upstream>
+</pkgmetadata>