summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-11 08:22:16 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-11 08:54:06 +0100
commitcf678e9093cc63840ee26ab6398c5033b61c3b05 (patch)
tree9c61d2ba62c80362f755c5d0bb251556bc5e7743 /dev-python/git-python/git-python-1.0.2.ebuild
parentsys-kernel/raspberrypi-sources: drop non-lts 3.19.9999 (diff)
downloadgentoo-cf678e9093cc63840ee26ab6398c5033b61c3b05.tar.gz
gentoo-cf678e9093cc63840ee26ab6398c5033b61c3b05.tar.bz2
gentoo-cf678e9093cc63840ee26ab6398c5033b61c3b05.zip
dev-python/git-python: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/git-python/git-python-1.0.2.ebuild')
-rw-r--r--dev-python/git-python/git-python-1.0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/git-python/git-python-1.0.2.ebuild b/dev-python/git-python/git-python-1.0.2.ebuild
new file mode 100644
index 000000000000..e7daa4265be0
--- /dev/null
+++ b/dev-python/git-python/git-python-1.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="GitPython"
+MY_PV="${PV/_rc/.RC}"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="http://gitorious.org/git-python https://pypi.python.org/pypi/GitPython"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# Tests dont make sense without a git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+# $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+# is the correct entry for mock, however while RESTRICT="test"
+# there is little point in setting it since it is inactive
+S="${WORKDIR}/${MY_P}"