summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-10-22 19:20:02 +0200
committerDennis Lamm <expeditioneer@gentoo.org>2020-10-22 21:24:05 +0200
commit4f5d1c58b9325ca5fcfb7215da8a6c71d0d5f32c (patch)
tree15587ecd1d6ca372e1477cf89932b6be543af3e0 /dev-python/glooey
parentwww-client/seamonkey: Removed old (diff)
downloadgentoo-4f5d1c58b9325ca5fcfb7215da8a6c71d0d5f32c.tar.gz
gentoo-4f5d1c58b9325ca5fcfb7215da8a6c71d0d5f32c.tar.bz2
gentoo-4f5d1c58b9325ca5fcfb7215da8a6c71d0d5f32c.zip
dev-python/glooey: bump 0.3.4
Bug: https://bugs.gentoo.org/748300 Signed-off-by: Dennis Lamm <expeditoneer@gentoo.org> Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/glooey')
-rw-r--r--dev-python/glooey/Manifest1
-rw-r--r--dev-python/glooey/glooey-0.3.4.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/glooey/Manifest b/dev-python/glooey/Manifest
index f4987002ca4d..f36f454934e0 100644
--- a/dev-python/glooey/Manifest
+++ b/dev-python/glooey/Manifest
@@ -1 +1,2 @@
DIST glooey-0.3.1.tar.gz 19110562 BLAKE2B 252621789def523e3f8535ff6d72d3b5e71664cc5a0b2b4440b64be8170c08f275709c1771d2ab154349da643a521dae352e711b7f0a705f0e6eaeb1bd842932 SHA512 c804125bc9ccd9f2b44cc5fcf5a0c7353402aa8587641fc75870bf0c2474c449936dd41ddc641050009f32dbaef4e05fecd4c60c477c0c89512a02028f957c65
+DIST glooey-0.3.4.tar.gz 19113011 BLAKE2B 45be6355ad51fd9a77003a39f8532f4a86bb3ba758d8fb56d483399ae2d876ff5f072e6f0c6a64ce71b493b650f5e09b553b3d97d8b73c6e2dbdfb789d427f47 SHA512 12222b336f0d1f720b6eb5b2a24eeba8bfa3d39c0775ffc8b9687a6720d8282f263da55cae653ccc1f610db0708a6c75671ca98969accaf0d02320815244ecbf
diff --git a/dev-python/glooey/glooey-0.3.4.ebuild b/dev-python/glooey/glooey-0.3.4.ebuild
new file mode 100644
index 000000000000..417a632f9cdd
--- /dev/null
+++ b/dev-python/glooey/glooey-0.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=(python3_{6..9})
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="An object-oriented GUI library for pyglet"
+HOMEPAGE="https://glooey.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/autoprop[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/vecrec[${PYTHON_USEDEP}]
+"
+
+BDEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}