summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-11-25 14:17:07 -0800
committerZac Medico <zmedico@gentoo.org>2015-11-25 14:17:07 -0800
commit91135bba0055e4260f98610985155b416609a94e (patch)
treebd92f17a47a915d3f3c65a37015fa338ee5196d5 /dev-python/google-api-python-client/google-api-python-client-1.4.2.ebuild
parentdev-python/pythondialog: Add version that supports python2 (diff)
downloadgentoo-91135bba0055e4260f98610985155b416609a94e.tar.gz
gentoo-91135bba0055e4260f98610985155b416609a94e.tar.bz2
gentoo-91135bba0055e4260f98610985155b416609a94e.zip
dev-python/google-api-python-client: version bump to 1.4.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-1.4.2.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.4.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.4.2.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.4.2.ebuild
new file mode 100644
index 000000000000..bd55bbb1a890
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://code.google.com/p/google-api-python-client/ https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/uritemplate[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all(){
+ export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 || die
+}