summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-13 05:28:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-13 05:38:06 +0100
commit2bad728e6095685af4ee4f30ada566176a8f56af (patch)
treef7c673011c55e88d00b66261614d099f614e1850 /dev-python/google-api-python-client
parentapp-admin/awscli: Bump to 1.31.13 (diff)
downloadgentoo-2bad728e6095685af4ee4f30ada566176a8f56af.tar.gz
gentoo-2bad728e6095685af4ee4f30ada566176a8f56af.tar.bz2
gentoo-2bad728e6095685af4ee4f30ada566176a8f56af.zip
dev-python/google-api-python-client: Bump to 2.111.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.111.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 8e077c03fb5f..0ae93fd76b73 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.108.0.tar.gz 12227437 BLAKE2B 7b8023f0e940730539bbfed2c213f6ec007b4e838eb87d8c7bd037c5f6dd73cbf97cdb6cec869d10f4c0135ff2989e1fa0b6a4b51cc118e7be2e45e2488d3b76 SHA512 baff038d8161de7150ac877dcca3af8a7f38fc9cfcdae9e70bdaf877f11fa35f572102ec1b6eda47a24f26386638285fc0ff31fbeb185d9174a40ca90cf20ba3
DIST google-api-python-client-2.109.0.tar.gz 12264648 BLAKE2B b0ff31b5e770f38ac44569a3480a9d0a28988441a907c823be7603fd3a48a5d407aeafdc6de5e8cadf32693f3363f0231f82e692fdeabe1ceb42eaeb5c99595b SHA512 1e5cd06a49548536b53411aa247f9118e808b97dd4b110f614347329f148ba9bc89514e5c205c7e7a90f52c53ab944a3a16afa833dc4a458d9ab53dc093bad63
DIST google-api-python-client-2.110.0.tar.gz 12416779 BLAKE2B 4b8bf928262db5d66d3201aaa2541cfd2ea9c5276528a8cee285eaafbb6947419d40c7335c3b131b9208e4a5c9c1e3c5df695bdd66a0a8b5736ea79d24ae1547 SHA512 a100b2a33c2944b8c5044c40cfdee4911e44fc1b366d4fd66cd99fd35c47058113f89c952b24d47b4ac3db573be30af1351d9b4e0d10b69e1ef5c5e5499f891b
+DIST google-api-python-client-2.111.0.tar.gz 12461105 BLAKE2B 3aa1de35867fbf2287fc4f0aadf4dc77aeb62bc0d894bcaf546ca00e062de289c83a732298ad6b09927d60bb1e3ea47e0a20fb108e23cb7af222e67a6e45d464 SHA512 3eb9a4580c6b59dbd7dff1f0ca9f309e92d7f75ce6d3085833d96c72751212a47073ef2b322ad85bc2795e82c85b9b80593f18a7335cc7438b0acaa94cbf04f5
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.111.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.111.0.ebuild
new file mode 100644
index 000000000000..0194f9640998
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.111.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}