summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-07 19:12:10 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-07 19:45:31 +0200
commit621f7839f460411274cbee0319014dbaae648f38 (patch)
tree511a15ce88534f1e5fa0b270f126e53211e4703d /dev-python/google-api-python-client
parentdev-python/sqlglot: Bump to 23.14.0 (diff)
downloadgentoo-621f7839f460411274cbee0319014dbaae648f38.tar.gz
gentoo-621f7839f460411274cbee0319014dbaae648f38.tar.bz2
gentoo-621f7839f460411274cbee0319014dbaae648f38.zip
dev-python/google-api-python-client: Bump to 2.128.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.128.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 94f531102c7f..c4e70d73ee62 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.126.0.tar.gz 12163106 BLAKE2B b66240ea914b1f673bd96e161e2fdffa4567641471594b166258331c04d5f43cc1a0c6f888cafd904b0b84d3afe5befbf437c347409da6197b4f801c6a15b7a1 SHA512 e21d98106a97de4037d9eead2b2153010d75a07bc00585a8a4d0a584b3da1bd753421ef33fa635a62c850235eede880f34ed222c2b0ede13ba93e7e1558d7cf5
DIST google-api-python-client-2.127.0.tar.gz 12203690 BLAKE2B 9252bf772c1d52ffc7b658f5c53d6537073f30df4a201573db84e53ded1b4e9693fa293a28d4f00d0d345695ac90639109993afe70908bf22538a2fa5b4bb7f5 SHA512 06887845f769005a10339114bb9d274c685bfcbc37e99ba9ac055e34cf587a4d8c0a2723159b8b2f6f6a25612bc4cc8ec01b248db4fafe3f1e1e7056e4081bdc
+DIST google-api-python-client-2.128.0.tar.gz 11193400 BLAKE2B c9762dc89a2dda1bdf96f6ae4b4f3540627510900cfccd6153e2399be7d835afdd1513854a9f25577e24e7555aa81b9bc0df06e8685c3f39871233655c9dc083 SHA512 9edd8c9c7b6736e98652e2abc4e482fae176e72cf5b04521b9ca2d0a86b885766a956b451d78dab038a5cfc7d7709eb2a505f03a07393decc3f3be8673400c88
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.128.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.128.0.ebuild
new file mode 100644
index 000000000000..3961663be4b6
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.128.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}