summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-15 08:45:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-15 08:56:23 +0200
commit6d665bc7c06067e5d9972d78cb05a48cfa88b2a1 (patch)
treedcc1e8cce7bfef802d1f91ba81d24bd1e6410795 /dev-python/google-apitools/google-apitools-0.5.31.ebuild
parentgames-arcade/supertux: Bump to version 0.6.2. Removed old (diff)
downloadgentoo-6d665bc7c06067e5d9972d78cb05a48cfa88b2a1.tar.gz
gentoo-6d665bc7c06067e5d9972d78cb05a48cfa88b2a1.tar.bz2
gentoo-6d665bc7c06067e5d9972d78cb05a48cfa88b2a1.zip
dev-python/google-apitools: Bump to 0.5.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-apitools/google-apitools-0.5.31.ebuild')
-rw-r--r--dev-python/google-apitools/google-apitools-0.5.31.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/google-apitools/google-apitools-0.5.31.ebuild b/dev-python/google-apitools/google-apitools-0.5.31.ebuild
new file mode 100644
index 000000000000..1056f05e014a
--- /dev/null
+++ b/dev-python/google-apitools/google-apitools-0.5.31.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python library to manipulate Google APIs"
+HOMEPAGE="https://github.com/google/apitools"
+SRC_URI="https://github.com/google/apitools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/apitools-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.14[${PYTHON_USEDEP}]
+ >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+ >=dev-python/python-gflags-3.1.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
+ test? ( >=dev-python/mock-1.0.1[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests nose