summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2020-09-25 19:27:06 +0800
committerBenda Xu <heroxbd@gentoo.org>2020-09-25 19:27:06 +0800
commit2750108c90fbec1f7e916117d13b9acca7de001d (patch)
tree3f15533ff48ee725120c84748c82ebf87e9f6c14 /dev-python/google-auth-oauthlib
parentdev-python/gast: tested on Python 3.8. (diff)
downloadgentoo-2750108c90fbec1f7e916117d13b9acca7de001d.tar.gz
gentoo-2750108c90fbec1f7e916117d13b9acca7de001d.tar.bz2
gentoo-2750108c90fbec1f7e916117d13b9acca7de001d.zip
dev-python/google-auth-oauthlib: tested on Python 3.8.
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..ba3dc19e098d
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.4.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://pypi.org/project/google-auth-oauthlib/ https://github.com/googleapis/google-auth-library-python-oauthlib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"