summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:07:25 +0200
commit3ddfcd307ba310bb4864dade682a11c81d964bce (patch)
treeade49e5d79587972e92c7cb22cae34cb27bc15c9 /dev-python/google-auth
parentdev-python/gevent: Remove redundant versions (diff)
downloadgentoo-3ddfcd307ba310bb4864dade682a11c81d964bce.tar.gz
gentoo-3ddfcd307ba310bb4864dade682a11c81d964bce.tar.bz2
gentoo-3ddfcd307ba310bb4864dade682a11c81d964bce.zip
dev-python/google-auth: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.0.1.ebuild51
-rw-r--r--dev-python/google-auth/google-auth-1.14.3.ebuild49
3 files changed, 0 insertions, 101 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 16d27171dde2..a06ff05f25c6 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,3 +1,2 @@
-DIST google-auth-1.0.1.tar.gz 133903 BLAKE2B 0a99dcdb37a195f24077162ea8191e2eb12aac0eec8e08d06f0b17aba9c4f5ed44f19ca41c737a249611ce02b98e03474d1e995909c5755222605e004d11fb1d SHA512 c10822c6b75700503a06a4b3a43a123d57605a043eb494bcb0232cc3941fc039d0803ed75be26d0da72fd4df613135c290fb3fdf82b0fa47d4fe0729462d80f4
DIST google-auth-1.14.3.tar.gz 101964 BLAKE2B 096768066d02248a4b614e5ea1f1035c81714ef09f6fb43fdb3ecc308d7cadaf7ad821f1dca505389fd1c73eec5e0b2d233f71f54469c43a2616f64a15661f21 SHA512 e3b76907e50b4927aaa1d450a6133943ad736427a180023ea2c4639545449769136b9db89eae54456338f1cf5bbaaa5840a8cf3db92d54f9e96407ae8935a607
DIST google-auth-1.20.1.tar.gz 107375 BLAKE2B 2f57cd9752c46891c59ed13e2ec8c6f98e5b3cd07d329769a78872877a17580c1ff5bb9da0381ef9bd4b6b9f72f04125ef71102543cfe1dc7bc3b09a5d5d9039 SHA512 6aad44b58c71f96c686606d6e8b6f273c64ce1559737920ccc31ad761442cad7f5fab19a59daee9408b284405a00c2de769c00221ac91bcfdd48851dba6f680f
diff --git a/dev-python/google-auth/google-auth-1.0.1.ebuild b/dev-python/google-auth/google-auth-1.0.1.ebuild
deleted file mode 100644
index 553ccb457d1c..000000000000
--- a/dev-python/google-auth/google-auth-1.0.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="https://pypi.org/project/google-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # urllib3-1.16 raised MaxRetryError, not TransportError
- sed -e 's:test_connection_error:_\0:' -i tests/transport/compliance.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # delete stray files included in the tarball
- find "${S}"/tests -name '*.pyc' -delete || die
- py.test || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/google-auth/google-auth-1.14.3.ebuild b/dev-python/google-auth/google-auth-1.14.3.ebuild
deleted file mode 100644
index d8c5e1666e88..000000000000
--- a/dev-python/google-auth/google-auth-1.14.3.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google Authentication Library"
-HOMEPAGE="https://github.com/GoogleCloudPlatform/google-auth-library-python https://pypi.org/project/google-auth/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-# Test deps need keywords. See #723554 and #723912.
-RESTRICT="test"
-
-RDEPEND="
- dev-python/namespace-google[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # delete stray files included in the tarball
- find "${S}"/tests -name '*.pyc' -delete || die
- sed -e 's|"rsa>=3.1.4,<4.1"|"rsa>=3.1.4"|' -i setup.py || die
- distutils-r1_src_prepare
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- find "${ED}" -name '*.pth' -delete || die
-}