summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-12-14 18:34:16 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-12-14 18:47:02 -0800
commit61cd5b919320e21622be64921a8675ef7f1d7d09 (patch)
tree398c5cb8b2d6979f2561a10afc49deb2400fa507 /dev-python/google-auth
parentdev-python/googleapis-common-protos-1.52.0: Version bump (diff)
downloadgentoo-61cd5b919320e21622be64921a8675ef7f1d7d09.tar.gz
gentoo-61cd5b919320e21622be64921a8675ef7f1d7d09.tar.bz2
gentoo-61cd5b919320e21622be64921a8675ef7f1d7d09.zip
dev-python/google-auth-1.24.0: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.24.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 317d5c49f9ba..a31de1663821 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1 +1,2 @@
DIST google-auth-1.20.1.tar.gz 107375 BLAKE2B 2f57cd9752c46891c59ed13e2ec8c6f98e5b3cd07d329769a78872877a17580c1ff5bb9da0381ef9bd4b6b9f72f04125ef71102543cfe1dc7bc3b09a5d5d9039 SHA512 6aad44b58c71f96c686606d6e8b6f273c64ce1559737920ccc31ad761442cad7f5fab19a59daee9408b284405a00c2de769c00221ac91bcfdd48851dba6f680f
+DIST google-auth-1.24.0.tar.gz 120351 BLAKE2B b0a78ad87622bc806cce72847d5dad3844afe080ffbcd822575dab6208952806360bed4e8756133d5b4fe2755f6cbeeb239b8f51634dd3d4cede9346372b689a SHA512 3e678dd946eb6c3c865cd35df1480a96ed35cf14b973f2239c5213b223a6569b4a9642609ac51243af75c662a08bbf0518d8592db97af297cf67c52b83019e30
diff --git a/dev-python/google-auth/google-auth-1.24.0.ebuild b/dev-python/google-auth/google-auth-1.24.0.ebuild
new file mode 100644
index 000000000000..f33fd88d8afa
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.24.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="https://github.com/GoogleCloudPlatform/google-auth-library-python https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # delete stray files included in the tarball
+ find "${S}"/tests -name '*.pyc' -delete || die
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}