summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-14 23:48:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-14 23:48:40 +0200
commitb9bdd4bd7855a96cbd822344507f11c8df8acb24 (patch)
tree76fc3699b5ce4ae1ae75d54e80cdb35e40a06ae7 /dev-python/google-auth
parentdev-python/sqlalchemy: Bump to 1.4.21 (diff)
downloadgentoo-b9bdd4bd7855a96cbd822344507f11c8df8acb24.tar.gz
gentoo-b9bdd4bd7855a96cbd822344507f11c8df8acb24.tar.bz2
gentoo-b9bdd4bd7855a96cbd822344507f11c8df8acb24.zip
dev-python/google-auth: Bump to 1.33.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-1.33.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 6196fb737354..06418480ac75 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1,2 +1,3 @@
DIST google-auth-1.30.2.tar.gz 169368 BLAKE2B c01191313b4bd7ffdc62fbca20aeadcb01fcb1f26e4c11504f88c2582b9a3dca10046edd5d2fe88c98980fb09e4d68da99bf0b8b5692abcf5271994515f91765 SHA512 f133ef403f8a3c92437055f2fd0e5f607199a0bfd9a76a44075a9be8ec16c4d4822d58d85fa52ade4c448e11cb6822f7e8da03ab72f3dddfb811c8d7a846f841
DIST google-auth-1.32.1.tar.gz 171621 BLAKE2B e82f4666a38d3dbaa4aa4a4d5192afb711471432c0dcca44b1a1c52fa2171f1de0d7ffd8a7a6d5dc6dbc3a1dec16becabb26306a9ba3b3fd0998584dd1194cc6 SHA512 968c16c7fc5c8c589a94e24139c319ec7f2791b021d6240156d398d4795e6afee8e46591c4aa44457de6f98ca14e8edcb055fb3a02914b43ba5fab74a03d9fc6
+DIST google-auth-1.33.0.tar.gz 178385 BLAKE2B 7d98afcd3a1dfc12a2af48297188c10f9618483ebdeeb8f7e02fca59d6255210a64b4917507a4525a3d6838198035fd827a1276da2a1f06169e83d1ca75fb485 SHA512 19da14b89cac28cf824f258d3dc662cbf40f4227e840594148c7ea3a6640dc00f06653c1b29846a9569d938a0fa307aff1c8425c015ab46d276485210eeb1227
diff --git a/dev-python/google-auth/google-auth-1.33.0.ebuild b/dev-python/google-auth/google-auth-1.33.0.ebuild
new file mode 100644
index 000000000000..2bb9e016a997
--- /dev/null
+++ b/dev-python/google-auth/google-auth-1.33.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/cachetools-2.0.0[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}