summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 09:55:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 10:56:36 +0200
commitd640db12c6caffb56fa9d627f2b06cbebb4d54a3 (patch)
tree402cfb863ffcb3caf57d72b1eebb3d1e1230f9a1 /dev-python/google-auth
parentdev-python/PyPDF2: Bump to 1.27.0 (diff)
downloadgentoo-d640db12c6caffb56fa9d627f2b06cbebb4d54a3.tar.gz
gentoo-d640db12c6caffb56fa9d627f2b06cbebb4d54a3.tar.bz2
gentoo-d640db12c6caffb56fa9d627f2b06cbebb4d54a3.zip
dev-python/google-auth: Bump to 2.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.6.3.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 9464b000e9b3..3e3c29564f14 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -3,3 +3,4 @@ DIST google-auth-2.4.0.tar.gz 188032 BLAKE2B 27cd5a9fec2a0f98e26e4c5cfada446f956
DIST google-auth-2.5.0.tar.gz 189396 BLAKE2B 85b6cccf46acaa15ebc58b0cc4ea906c405e8f5e1f9d5c67c1790105689bba47e9f57355751a31a051ec6f20f828e2e2d0d9e792afc5d877791deab8a3e18503 SHA512 7323f253789364d14c1c1adf148cbfff2abceec06c539e93c8f5ae4a5ee978838480f9923e3d62988d903a239434257f980ec1095a8cedc678e263d0adff6cce
DIST google-auth-2.6.0.tar.gz 188477 BLAKE2B 19baf9ec41e2b8667b8800687f4920d0e53df6cbfd17830e352f808b1438b21d952a4480f3b0fbc8e83dd215c0cd49b393f4798952eea1eb808b5417d578af85 SHA512 160fae0afcebd62dc0d46bf5e1102be34c6084cf188941105facd00b4a9b2bf6b36b58623e84595111849af0cb16b4f4a09b1e13ce095be025831fa4e7241b4c
DIST google-auth-2.6.2.tar.gz 189490 BLAKE2B 5506b4d316a40274cd8ce0cea8c6a76b882e14f4f7e28f5a50e67c8828353d3078f713f874e36ba4c81537228325cf19c7ea1c3040b04d4b6338e456a8622024 SHA512 196bcec8f90ddc7ba95f03576f496aab38526c2305d729db806f07c0b44e578c6bfcb3a79224f4edaacb8760a3c7bb17a0af90cb2986aff3fdc5f767328fb247
+DIST google-auth-2.6.3.tar.gz 189685 BLAKE2B 68718ce4031c4e764dcfec19361b034ed5e1efa602d5c734b61a853020f40aaa856f9d9a3b964470e148fbfcb081dbc7d2c8bf0a53fc843d9360dbc72623bcdf SHA512 cba3228dbc0887c127d50cc45eb134e3a0b2bea044b8a1e65807918a3808e550fd58217a236c07b6cb908e5a080d9c1c1a2e9ee1853968d8c0bd50b7228ea262
diff --git a/dev-python/google-auth/google-auth-2.6.3.ebuild b/dev-python/google-auth/google-auth-2.6.3.ebuild
new file mode 100644
index 000000000000..ae67ca59c308
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.6.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ dev-python/namespace-google[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/grpcio[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+)
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}