summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-10-25 17:07:58 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-10-25 17:11:48 -0700
commit2ccc98f6ff00eaed3950b67102effe7b27f34978 (patch)
treee6a29dc818b833b1f20587494ee65b87892f6003 /dev-python/grpcio
parentnet-libs/grpc: bump to 1.24.3 (diff)
downloadgentoo-2ccc98f6ff00eaed3950b67102effe7b27f34978.tar.gz
gentoo-2ccc98f6ff00eaed3950b67102effe7b27f34978.tar.bz2
gentoo-2ccc98f6ff00eaed3950b67102effe7b27f34978.zip
dev-python/grpcio: bump to 1.24.3
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.24.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 5aa029379720..49268ad89264 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -6,3 +6,4 @@ DIST grpcio-1.20.1.tar.gz 13882426 BLAKE2B 4211d9dedc7ba858a5124798f17b3b158f255
DIST grpcio-1.21.1.tar.gz 13919484 BLAKE2B dcad98da8db4aa588facc30d1b010ec1e4d5f8085751422277631329f1c4949ba3e2c3882829354025a845992ba9972df1c48a277df93caef9015969f9423aef SHA512 0ea20490ce5e776a6253d4b89dd9d9091afb7462d6bd6bd9d2d3329979d61360a3e31abbd043b90d0908512cf7ff2668bb21cb472fbf0ad5a3b5963073850dd7
DIST grpcio-1.22.1.tar.gz 13923342 BLAKE2B 6d211b93a7597f568d106e0d6e3d30b90d7b4bf6fae42b163f2ae04e01c4b323c4d7c2a5380ccdbab14f9a6986c86fae4948bc827a97c189f915bc24738fc426 SHA512 5392041a021b0523fc7a615070ea0f907fc960cb69ffba1e7fcdf0aa8e498cb33f567d9eec795dc06662f558884dcabcc17a1ae4a26fcaa479b0a43c08e8b913
DIST grpcio-1.23.0.tar.gz 13977223 BLAKE2B b9f95aaf397eae9610280937980e4b2694af98e6cd5f80015dd83c67ec6bf9c41e76474f873627d6c6cc35fe9af3b45f14aabb6ea809b51cf5f0bb0f3b702794 SHA512 ff3cd9d2380a158ea7a49ba2c9cd5bd1ec98194aa48cf2d45596ab93f0e8a6d6ed0291e5dfc52bca79c62950e6a0ce387819d19f036c0dd1e6dc7b737c1ee97f
+DIST grpcio-1.24.3.tar.gz 14030592 BLAKE2B aa9e61c692937d7fc06d0fb601f7632a6ac5fb165aabec9e7993cf1fa41254b004fff89f650f390544e5fb1972dca542169ce0fdae79a71d775fe3cbb44a2d95 SHA512 0dc90de5a06b9af7fa91d3e96117f69813e5fee31499e8e48daac7d164856594f164a434d3dd28d6e0220e417926aadceabb9b7597e86a6bb87d8943e6661dce
diff --git a/dev-python/grpcio/grpcio-1.24.3.ebuild b/dev-python/grpcio/grpcio-1.24.3.ebuild
new file mode 100644
index 000000000000..bcf535535b98
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.24.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ !<net-libs/grpc-1.16.0[python]
+ sys-libs/zlib:=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_configure_all() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}