summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-02-26 20:05:50 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-02-26 20:19:36 -0800
commit61e35b1f9a42b9c29c80a6bf1bdd7589d5eee3ff (patch)
tree29f3d5c3bb3788ab6c68e6166a9815c130324884 /dev-python/grpcio
parentnet-libs/grpc: bump to 1.19.0 (diff)
downloadgentoo-61e35b1f9a42b9c29c80a6bf1bdd7589d5eee3ff.tar.gz
gentoo-61e35b1f9a42b9c29c80a6bf1bdd7589d5eee3ff.tar.bz2
gentoo-61e35b1f9a42b9c29c80a6bf1bdd7589d5eee3ff.zip
dev-python/grpcio: bump to 1.19.0
add experimental python3.7 support add protobuf-python dep Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.19.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 71b6406f3526..8f1a2ce09c31 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1,3 +1,4 @@
DIST grpcio-1.16.1.tar.gz 14514047 BLAKE2B e4fc7f196f3e377afb0a103aca60337dd63b3b0f84846e7e2a4622a0102d4300782f08367e1429e1fd021dd90b151f17dd927a25a749f35724c7d2a41a6943a6 SHA512 efd7fb36a61e2ee872c0807a8198cabe8f1f9003bd5bce7cd46c75541752c0f745db02bbfe3f37f572531e15df60913f2b08b678545f176fe683f3e64e22124f
DIST grpcio-1.17.1.tar.gz 14563233 BLAKE2B 61ccfaa967ee348f02f5a201e4f36f25d4fa09a1af11c6b5a0f345d13bf86f0fb12c3aea125c5bc27925698e0a23a9592806fe5db92fa37360cdcaf88e596189 SHA512 bf8dc6b7ce2f4a0765377fbae085395caef9f0cd0a2b4a779b3bf1667c6aba5fff034168bff9539f96dea76b2c97d7586305715c850d10e54918337458a4ee95
DIST grpcio-1.18.0.tar.gz 14601124 BLAKE2B 4dc57243759c573b960e841def6af335f490fc6aa285f88979b4c66365b104a84269688c589ed7ae797527b04124a9997937f5bf33b179978077b2b680e515f5 SHA512 da791a418e0f6f3a7be921e107586837edcd2020dc8dab1107712372ebd4896b6b94e00d7501ed957e4ab0d5f7d6a3f2b57477ff33c55eb5e4ad7828b2f21624
+DIST grpcio-1.19.0.tar.gz 14621509 BLAKE2B b756ba60d317baa089b8ee57c458bc68fb72e61a87150f1ef3366fea23456ca8d5bd443ba1579d1bef5d0049f249fc8c2c6e7c7cc0967eb58c102fb03d783103 SHA512 620459dd1a22cf60cb6bccb1b7dd64175f1efdfc098152cfa1889ad0a727b7a92b72f9de28b57e9a45cc8d2c22e2fc36307af8ab52ced454a91aedeaf7158273
diff --git a/dev-python/grpcio/grpcio-1.19.0.ebuild b/dev-python/grpcio/grpcio-1.19.0.ebuild
new file mode 100644
index 000000000000..63c7aaebcf49
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.19.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ !<net-libs/grpc-1.16.0[python]
+ sys-libs/zlib:=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ distutils-r1_python_compile
+}