summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-14 21:49:47 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-14 21:49:47 -0800
commit6af6897d53084a884ec953a90f15a4c340a71874 (patch)
treebd837f35c3c8da1495febf53675e60cce11e25c5 /dev-python/grpcio
parentnet-libs/grpc: bump to 1.17.1 (diff)
downloadgentoo-6af6897d53084a884ec953a90f15a4c340a71874.tar.gz
gentoo-6af6897d53084a884ec953a90f15a4c340a71874.tar.bz2
gentoo-6af6897d53084a884ec953a90f15a4c340a71874.zip
dev-python/grpcio: bump to 1.17.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.17.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 4f438235f943..00a2eb96bc58 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1,3 +1,4 @@
DIST grpcio-1.16.0.tar.gz 14519470 BLAKE2B 872ef15a7994303ce7ac0a573e49c94260eb8480d8ee94e25471ec9395827fafd3f5e3bd6f4793eb15091827e6d780b8dd6d01f38eef85db80fb234a710f370b SHA512 37d5940f1543cebdabf2b1340a042f98e5f321c42d92d05c88631c0eae42d94d3fe86893a21704a22b70c1fbd70bf091c1af2b51cd5c1d316dd8f0a586fb0eb7
DIST grpcio-1.16.1.tar.gz 14514047 BLAKE2B e4fc7f196f3e377afb0a103aca60337dd63b3b0f84846e7e2a4622a0102d4300782f08367e1429e1fd021dd90b151f17dd927a25a749f35724c7d2a41a6943a6 SHA512 efd7fb36a61e2ee872c0807a8198cabe8f1f9003bd5bce7cd46c75541752c0f745db02bbfe3f37f572531e15df60913f2b08b678545f176fe683f3e64e22124f
DIST grpcio-1.17.0.tar.gz 14563132 BLAKE2B fd9b4f1f0ce4b42c56edcda35e1865627ded48de74c828020547340cb2417df576705187cb4495668a10b603f13f0b2fdaa030aeccdfa8cd2a6e0b4e7574bcf9 SHA512 2af696639bd995e8df905bdec88f8d4c9d1973282438181474c9662cb9e72916cd5fa843ba61ecb90d834e5d7d70c063c4b81aae889be1bf9d3f0ce804440305
+DIST grpcio-1.17.1.tar.gz 14563233 BLAKE2B 61ccfaa967ee348f02f5a201e4f36f25d4fa09a1af11c6b5a0f345d13bf86f0fb12c3aea125c5bc27925698e0a23a9592806fe5db92fa37360cdcaf88e596189 SHA512 bf8dc6b7ce2f4a0765377fbae085395caef9f0cd0a2b4a779b3bf1667c6aba5fff034168bff9539f96dea76b2c97d7586305715c850d10e54918337458a4ee95
diff --git a/dev-python/grpcio/grpcio-1.17.1.ebuild b/dev-python/grpcio/grpcio-1.17.1.ebuild
new file mode 100644
index 000000000000..ef464d3ecc68
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.17.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ !<net-libs/grpc-1.16.0[python]
+ sys-libs/zlib:=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ distutils-r1_python_compile
+}