summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-07-13 18:07:32 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-07-13 18:10:01 -0700
commitc0ca9b5879de84d92ad34361ca3ac42e5e5c5433 (patch)
treed7b4954cf1473d707351f2b9b30b8e43032f6f6c /dev-python/grpcio
parentnet-libs/grpc: bump to 1.22.0 (diff)
downloadgentoo-c0ca9b5879de84d92ad34361ca3ac42e5e5c5433.tar.gz
gentoo-c0ca9b5879de84d92ad34361ca3ac42e5e5c5433.tar.bz2
gentoo-c0ca9b5879de84d92ad34361ca3ac42e5e5c5433.zip
dev-python/grpcio: bump to 1.22.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/grpcio')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.22.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index 8e4dd86ee973..64ee49ad70ae 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -4,3 +4,4 @@ DIST grpcio-1.18.0.tar.gz 14601124 BLAKE2B 4dc57243759c573b960e841def6af335f490f
DIST grpcio-1.19.0.tar.gz 14621509 BLAKE2B b756ba60d317baa089b8ee57c458bc68fb72e61a87150f1ef3366fea23456ca8d5bd443ba1579d1bef5d0049f249fc8c2c6e7c7cc0967eb58c102fb03d783103 SHA512 620459dd1a22cf60cb6bccb1b7dd64175f1efdfc098152cfa1889ad0a727b7a92b72f9de28b57e9a45cc8d2c22e2fc36307af8ab52ced454a91aedeaf7158273
DIST grpcio-1.20.1.tar.gz 13882426 BLAKE2B 4211d9dedc7ba858a5124798f17b3b158f255d055f32f5947191fcb5fd45cca9c97aa3f8c4966e7195add5289ba3747a77b2f0c01a35762ffbeba6938c76046d SHA512 0ac126d8b2c25204bb03daccfc9b17016bc18dd31f89f6e208f2ae39d7e6fd17ae04a8178367a5334421d959b14fd3d31ac71a692b48a060d98f983553fcc3e2
DIST grpcio-1.21.1.tar.gz 13919484 BLAKE2B dcad98da8db4aa588facc30d1b010ec1e4d5f8085751422277631329f1c4949ba3e2c3882829354025a845992ba9972df1c48a277df93caef9015969f9423aef SHA512 0ea20490ce5e776a6253d4b89dd9d9091afb7462d6bd6bd9d2d3329979d61360a3e31abbd043b90d0908512cf7ff2668bb21cb472fbf0ad5a3b5963073850dd7
+DIST grpcio-1.22.0.tar.gz 13925872 BLAKE2B 96cb2244e6fe11c628349b21026906336981d51661474f4e871ad33125cd183255cd9eb2de2eca9af00f80ddd1989dde80e60cdbe5bc833225980c63e12c92fc SHA512 912672209e2192fadaef79fe6cd79575d386e54ca0362f43e8e7138ca1f3673ea6a55f884257e9fb1780bae78664816675279a7f5ee799cc5d25ae43287729b1
diff --git a/dev-python/grpcio/grpcio-1.22.0.ebuild b/dev-python/grpcio/grpcio-1.22.0.ebuild
new file mode 100644
index 000000000000..095bde11b67c
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.22.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ >=dev-python/cython-0.28.3[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ !<net-libs/grpc-1.16.0[python]
+ sys-libs/zlib:=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_configure_all() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ export GRPC_PYTHON_BUILD_EXT_COMPILER_JOBS="$(makeopts_jobs)"
+}