summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-03 16:14:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-03 18:09:17 +0200
commit813f525309e12f4da53b06dd740f1a063a7f7053 (patch)
treee09fc7bd4280226279513e3940f0f2f3ddb24dca /dev-python/guessit
parentpackage.mask: Rescue dev-python/guessit (diff)
downloadgentoo-813f525309e12f4da53b06dd740f1a063a7f7053.tar.gz
gentoo-813f525309e12f4da53b06dd740f1a063a7f7053.tar.bz2
gentoo-813f525309e12f4da53b06dd740f1a063a7f7053.zip
dev-python/guessit: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/guessit')
-rw-r--r--dev-python/guessit/Manifest1
-rw-r--r--dev-python/guessit/guessit-3.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/guessit/Manifest b/dev-python/guessit/Manifest
index 03c79c7d97af..97cb5b895ba5 100644
--- a/dev-python/guessit/Manifest
+++ b/dev-python/guessit/Manifest
@@ -1 +1,2 @@
DIST guessit-3.0.0.tar.gz 133379 BLAKE2B c9d7c2def91dc301944b951bfa32810b9efd2348fa9a016015dd75c03b407bf3e17cc5cb93baa1d4cc5b6fcb76790972f2bf7c14af2c0cad419f6a98bdda3d6c SHA512 87f19dc1c6b4f46fa1f2682f7c3bab91cf094df06904b8d9771159f346612b9d0adef4aef55315dd00d07787319d17008e936b125941abba5b869df6a91cb1c6
+DIST guessit-3.1.1.tar.gz 147605 BLAKE2B 3b11747b652e922aada12ce771c1e91e8842c78c221ac39c068488ae6cae95ebc6d9f6d8849aaef11d522e2c7d6e6f8e34981179e48d9db649e811c5fa2e52ef SHA512 6a02c4024d286cf49c62e072bcb616a052cec1ce51d364b17cea1768504c4ecebba914a3bf5beda9a61dca0e7764c8642cb5b918a20fb25cdd7120ad1667825f
diff --git a/dev-python/guessit/guessit-3.1.1.ebuild b/dev-python/guessit/guessit-3.1.1.ebuild
new file mode 100644
index 000000000000..a502d292d254
--- /dev/null
+++ b/dev-python/guessit/guessit-3.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for guessing information from video filenames"
+HOMEPAGE="https://github.com/guessit-io/guessit
+ https://pypi.org/project/guessit/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/babelfish-0.5.5[${PYTHON_USEDEP}]
+ >=dev-python/rebulk-2.0.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Disable benchmarks as they require unavailable pytest-benchmark.
+ rm guessit/test/test_benchmark.py || die
+ sed -i -e "s|'pytest-benchmark',||g" setup.py || die
+
+ # Disable unconditional dependency on dev-python/pytest-runner.
+ sed -i -e "s|'pytest-runner'||g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}