summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-26 15:45:37 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-26 15:46:22 -0600
commitc8d88a067fce0fb2b2c696ac93534a177efb056f (patch)
tree7c81fc3e4645c8f59c8491453d445400a1577b01 /dev-python/hacking
parentdev-python/bandit: 1.5.1 stable x86 with cleanup (diff)
downloadgentoo-c8d88a067fce0fb2b2c696ac93534a177efb056f.tar.gz
gentoo-c8d88a067fce0fb2b2c696ac93534a177efb056f.tar.bz2
gentoo-c8d88a067fce0fb2b2c696ac93534a177efb056f.zip
dev-python/hacking: 1.1.0 removed
Closes: https://bugs.gentoo.org/643616 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/hacking')
-rw-r--r--dev-python/hacking/Manifest1
-rw-r--r--dev-python/hacking/hacking-1.1.0.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/hacking/Manifest b/dev-python/hacking/Manifest
index da8ad358afff..d716e3067de0 100644
--- a/dev-python/hacking/Manifest
+++ b/dev-python/hacking/Manifest
@@ -1,2 +1 @@
-DIST hacking-1.1.0.tar.gz 55620 BLAKE2B 6a6f30ef8a1eef3aa1b1b630dd43e1d2e9adff1623d8db19a545f186f60ce367e4b820582893e6444b7d58573b4a70a47a30cdc8d2ce1202666cf6e1b0e7456f SHA512 d326995976c04469c9d164ff31d02471346af715730d97fee23261988100156c4598ea8968cb483e8f386ee3f94a6bdffb5f67d8a7dfc238f4607fb7fe09e128
DIST hacking-2.0.0.tar.gz 53296 BLAKE2B 50606d700c324acc8695499ee97cd592b051fe0cfc020efdfe7bf82b44d2f6ac858ed2f923ea08343066820c7da1686aa0b172bbab541cc564dc5ecc016cfac6 SHA512 d44d62f694c79af4c2044e745b140f0582fb5a6bbfa8050d45b17e8cb354198e8eac3a06586cf96d516844bb079d429d73ce9755a23e256857c4de19aca7ffe3
diff --git a/dev-python/hacking/hacking-1.1.0.ebuild b/dev-python/hacking/hacking-1.1.0.ebuild
deleted file mode 100644
index 806a3495fd58..000000000000
--- a/dev-python/hacking/hacking-1.1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Nova API"
-HOMEPAGE="https://github.com/openstack-dev/hacking"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~hppa ~ppc64 ~s390 x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
- <dev-python/flake8-2.7.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- ${RDEPEND}
- )
- doc? (
- >=dev-python/sphinx-1.7.0[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- )"
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && sphinx-build -b html -c doc/source/ doc/source/ doc/source/html
-}
-
-python_test() {
- testr init || die "testr init died"
- testr run || die "testsuite failed under ${EPYTHON}"
- flake8 "${PN}"/tests || die "flake8 drew error on a run over ${PN}/tests folder"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/source/html/. )
- distutils-r1_python_install_all
-}