summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-12 16:23:29 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-12 16:33:19 +0100
commit270a037eb43cd2c96cee545482f2d986a1460f8a (patch)
tree37f7da08b7df47da33d18f1bfe62f2c4560520fd /dev-python/hatch-vcs
parentdev-python/PyPDF2: Bump to 2.12.1 (diff)
downloadgentoo-270a037eb43cd2c96cee545482f2d986a1460f8a.tar.gz
gentoo-270a037eb43cd2c96cee545482f2d986a1460f8a.tar.bz2
gentoo-270a037eb43cd2c96cee545482f2d986a1460f8a.zip
dev-python/hatch-vcs: Bump to 0.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hatch-vcs')
-rw-r--r--dev-python/hatch-vcs/Manifest1
-rw-r--r--dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/hatch-vcs/Manifest b/dev-python/hatch-vcs/Manifest
index 66ef5bcee709..daf205655281 100644
--- a/dev-python/hatch-vcs/Manifest
+++ b/dev-python/hatch-vcs/Manifest
@@ -1,2 +1,3 @@
DIST hatch-vcs-0.2.0.gh.tar.gz 8192 BLAKE2B 69f24de91b947e695336ca30cf3f265edcfaf10fa49df93fa0f70e45d1179e70d1ef5584fc99f88f66ca3c4fd1866a681db81253280ce3f9221d19f04443a085 SHA512 1c3627240ef5b659b9d87a69c84dd71cac4c83758f5be676e808377400383e996209cf6eabb1222f5330c0a97f0d261ced1eb9dc40e1d5c2bb2fc708659360eb
DIST hatch-vcs-0.2.1.gh.tar.gz 9070 BLAKE2B d06e6bb32f69308e63cff796ff5942b4ec93c773196572c9d748d39d5ca12d176d65d58bd2e953db21b1387d283f16f9f18ac6481f13d95329356054cdbdafe6 SHA512 5e18cf15ffb75a96cdcfa0d19b15aa2c6f31f7066c78e64aef0a27d64eb69512e402027b5c45fc81c65fea1033bea404fc20ae6c0c465ba4b05229079b88be45
+DIST hatch-vcs-0.3.0.gh.tar.gz 10049 BLAKE2B 69f49e205b4e42b46a246cc2403d8e7bbd2b8f83a360f1100ba98ecf7308d445e265749bd1f5fa7cca84104436e2643fd3f95292f2dba3dc48584a0df5136136 SHA512 ce22937aae8130a485ab154378f6c58c1720d66d277349a95ccfb58fd748deb69cd17d34ec3a12f3201f9e348e5d5b1c6b977432e614bb42d0e3065ec5f7f9c6
diff --git a/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild b/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
new file mode 100644
index 000000000000..064ed6285b21
--- /dev/null
+++ b/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hatch plugin for versioning with your preferred VCS"
+HOMEPAGE="
+ https://pypi.org/project/hatch-vcs/
+ https://github.com/ofek/hatch-vcs/
+"
+SRC_URI="
+ https://github.com/ofek/hatch-vcs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/setuptools_scm-6.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest