summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-02-12 22:01:52 -0500
committerMatt Turner <mattst88@gentoo.org>2023-02-12 22:02:13 -0500
commit2e43e38f24598f2626b6d4b0a6c0496ad284a8c3 (patch)
tree6ec44b62aa6f1cd1b26b3c7048912a1b0f95033f /dev-python/hatch-vcs
parentmedia-libs/stk: fix build (diff)
downloadgentoo-2e43e38f24598f2626b6d4b0a6c0496ad284a8c3.tar.gz
gentoo-2e43e38f24598f2626b6d4b0a6c0496ad284a8c3.tar.bz2
gentoo-2e43e38f24598f2626b6d4b0a6c0496ad284a8c3.zip
dev-python/hatch-vcs: Add patch to fix test suite
Closes: https://bugs.gentoo.org/865513 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/hatch-vcs')
-rw-r--r--dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch32
-rw-r--r--dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild4
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch b/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch
new file mode 100644
index 000000000000..919036acd720
--- /dev/null
+++ b/dev-python/hatch-vcs/files/hatch-vcs-0.3.0-Work-with-setuptools_scm-7.1-fix-25-26.patch
@@ -0,0 +1,32 @@
+From 47364faf5563df0eaa631ed10383817762c6b547 Mon Sep 17 00:00:00 2001
+From: Ben Beasley <code@musicinmybrain.net>
+Date: Thu, 5 Jan 2023 18:49:54 -0500
+Subject: [PATCH] Work with setuptools_scm 7.1 (fix #25) (#26)
+
+Make test_write less brittle (see also #8, #9) so that it works with
+_version.py files generated by at least setuptools_scm 7.1, 7.0, and
+6.x.
+---
+ tests/test_build.py | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_build.py b/tests/test_build.py
+index 2fde601..7c76343 100644
+--- a/tests/test_build.py
++++ b/tests/test_build.py
+@@ -75,8 +75,10 @@ def test_write(new_project_write):
+ assert os.path.isfile(version_file)
+
+ lines = read_file(version_file).splitlines()
+- assert lines[3].startswith(('version =', '__version__ ='))
+- assert lines[3].endswith("version = '1.2.3'")
++ version_starts = ('version = ', '__version__ = ')
++ assert any(line.startswith(version_starts) for line in lines)
++ version_line = next(line for line in lines if line.startswith(version_starts))
++ assert version_line.endswith(" = '1.2.3'")
+
+
+ @pytest.mark.skipif(sys.version_info[0] == 2, reason='Depends on fix in 6.4.0 which is Python 3-only')
+--
+2.39.1
+
diff --git a/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild b/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
index 56b375eb4b11..4f277c25e9ec 100644
--- a/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
+++ b/dev-python/hatch-vcs/hatch-vcs-0.3.0.ebuild
@@ -31,4 +31,8 @@ BDEPEND="
)
"
+PATCHES=(
+ "${FILESDIR}"/${P}-Work-with-setuptools_scm-7.1-fix-25-26.patch
+)
+
distutils_enable_tests pytest