summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2021-06-26 23:41:08 +0200
committerSven Wegener <swegener@gentoo.org>2021-06-26 23:41:51 +0200
commitbfa0b339d6094863dd89316d742775398880d483 (patch)
tree5a27b66274b9aaf8c804bca8eaed80928a08362c /dev-python/hiredis/hiredis-2.0.0.ebuild
parentdev-libs/libffi: bump up to 3.4_rc1, SOVERSION=8 (diff)
downloadgentoo-bfa0b339d6094863dd89316d742775398880d483.tar.gz
gentoo-bfa0b339d6094863dd89316d742775398880d483.tar.bz2
gentoo-bfa0b339d6094863dd89316d742775398880d483.zip
dev-python/hiredis: Version bump to 2.0.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Sven Wegener <swegener@gentoo.org>
Diffstat (limited to 'dev-python/hiredis/hiredis-2.0.0.ebuild')
-rw-r--r--dev-python/hiredis/hiredis-2.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/hiredis/hiredis-2.0.0.ebuild b/dev-python/hiredis/hiredis-2.0.0.ebuild
new file mode 100644
index 000000000000..c2881e5aae37
--- /dev/null
+++ b/dev-python/hiredis/hiredis-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="https://github.com/redis/hiredis-py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="system-libs"
+
+DEPEND="system-libs? ( dev-libs/hiredis:0/1.0.0 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ use system-libs && PATCHES+=(
+ "${FILESDIR}"/${P}-system-libs.patch
+ )
+ default
+}
+
+python_test() {
+ cd test || die
+ "${EPYTHON}" -m unittest reader.ReaderTest || die "tests failed"
+}