summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-15 19:03:59 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-21 10:28:06 +0200
commit799f003b7bb2caee47c47135bbaf980c19c45f2b (patch)
tree2626d1ff0ab553e4dddce6bc23df568e2809de72 /dev-python/hiro/hiro-0.5.ebuild
parentnet-p2p/retroshare: Drop obsolete gnome2_icon_savelist (diff)
downloadgentoo-799f003b7bb2caee47c47135bbaf980c19c45f2b.tar.gz
gentoo-799f003b7bb2caee47c47135bbaf980c19c45f2b.tar.bz2
gentoo-799f003b7bb2caee47c47135bbaf980c19c45f2b.zip
dev-python/hiro: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/hiro/hiro-0.5.ebuild')
-rw-r--r--dev-python/hiro/hiro-0.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/hiro/hiro-0.5.ebuild b/dev-python/hiro/hiro-0.5.ebuild
new file mode 100644
index 000000000000..76be991cb48d
--- /dev/null
+++ b/dev-python/hiro/hiro-0.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Time manipulation utilities for Python"
+HOMEPAGE="https://github.com/alisaifee/hiro"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"