summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2016-01-13 11:46:48 +0100
committerTomas Mozes <hydrapolic@gmail.com>2016-01-13 11:46:48 +0100
commit6fcf85cc22d692721a7c008d5aba28876969787b (patch)
tree5665ed51871731341bb4c406df3f5f85f436ae39 /dev-python/httmock/httmock-1.2.4.ebuild
parentapp-admin/ansible: Fix Version number (diff)
downloadgentoo-6fcf85cc22d692721a7c008d5aba28876969787b.tar.gz
gentoo-6fcf85cc22d692721a7c008d5aba28876969787b.tar.bz2
gentoo-6fcf85cc22d692721a7c008d5aba28876969787b.zip
dev-python/httmock: version bump to 1.2.4
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/httmock/httmock-1.2.4.ebuild')
-rw-r--r--dev-python/httmock/httmock-1.2.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/httmock/httmock-1.2.4.ebuild b/dev-python/httmock/httmock-1.2.4.ebuild
new file mode 100644
index 000000000000..3c941d08b27e
--- /dev/null
+++ b/dev-python/httmock/httmock-1.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A mocking library for requests"
+HOMEPAGE="https://github.com/patrys/httmock"
+SRC_URI="https://github.com/patrys/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/requests-1.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}