summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-18 12:47:04 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-18 12:57:03 +0200
commit2d48e156b37f0abd9c03e97ed98f83c41a6ee593 (patch)
tree5b8792d610f9c3bd1e7c78f1127d63e9d07a98ac /dev-python/http-parser
parentdev-python/numpydoc: Use pytest for tests (diff)
downloadgentoo-2d48e156b37f0abd9c03e97ed98f83c41a6ee593.tar.gz
gentoo-2d48e156b37f0abd9c03e97ed98f83c41a6ee593.tar.bz2
gentoo-2d48e156b37f0abd9c03e97ed98f83c41a6ee593.zip
dev-python/http-parser: Bump to 0.9.0
Closes: https://bugs.gentoo.org/723556 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/http-parser')
-rw-r--r--dev-python/http-parser/Manifest1
-rw-r--r--dev-python/http-parser/http-parser-0.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/http-parser/Manifest b/dev-python/http-parser/Manifest
index 0175a15c11a7..849b8b606ba3 100644
--- a/dev-python/http-parser/Manifest
+++ b/dev-python/http-parser/Manifest
@@ -1 +1,2 @@
DIST http-parser-0.8.3.tar.gz 83040 BLAKE2B 8ccfd15154e34756229159576340536e447a1b76375df7c3f56b96c79957a3b28569fd4a4e77303fd1d254aa5652478f7e319e7556150de563f5b12c58482de4 SHA512 aca583d976dcf172244179cc4199336f296dbb2e2838dded23e64d55f23298fe600f9c24ba6cb6d1d5faad3022710154949fd39adecaef763f7589a58d03fbd1
+DIST http-parser-0.9.0.gh.tar.gz 101174 BLAKE2B 92b74dffd2c35672bc383ccda59f93723c0f83ecb0fbf0470f5daacdd37f68d4d63de7d4ea53f86d2109349a793b7535cc864f014311dee6ac5e67d0ca751931 SHA512 75e51bef43d9d7698aad69f8bfe651e24784b97603cac55f33bf4c12c86792c8c71d6206f31847d052e4d8621a5ea65a7b34eca5bebdb8189f58e6d98d33139d
diff --git a/dev-python/http-parser/http-parser-0.9.0.ebuild b/dev-python/http-parser/http-parser-0.9.0.ebuild
new file mode 100644
index 000000000000..5a0b335f0ccb
--- /dev/null
+++ b/dev-python/http-parser/http-parser-0.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP request/response parser for python in C"
+HOMEPAGE="https://github.com/benoitc/http-parser"
+SRC_URI="
+ https://github.com/benoitc/http-parser/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ if [[ ${EPYTHON} != python3* ]]; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+
+ distutils-r1_python_compile
+}
+
+python_install_all() {
+ local DOCS=( README.rst )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}