summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-10 20:51:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-10 22:10:57 +0100
commit190671cbeee8e19ad6022cb38cae6831d78bae01 (patch)
treea4132f3aced3c7a82f9a5f27a2828cd77652b981 /dev-python/httpcore
parentdev-python/Faker: Bump to 20.0.0 (diff)
downloadgentoo-190671cbeee8e19ad6022cb38cae6831d78bae01.tar.gz
gentoo-190671cbeee8e19ad6022cb38cae6831d78bae01.tar.bz2
gentoo-190671cbeee8e19ad6022cb38cae6831d78bae01.zip
dev-python/httpcore: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-1.0.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 9007603a114b..3bdd537834ab 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1,3 +1,4 @@
DIST httpcore-0.18.0.gh.tar.gz 94594 BLAKE2B 9602397bc2aa5941e9bfbffb7ba3e751c4ecac29a76dede6fa45f190ac7514f2e081cc67b781a8b6152c85ca3bfb051bdbc34628b95d05eba25a307e8877faa7 SHA512 3dc8114bf02226fc4ac87408163e599f4e9f70f9e5663c9eb7dc9a65b2b72861f3b19ed2f87e29ac90a8b85c5dc32a3fffdaf88e83b15df838fcbd89737b1c57
DIST httpcore-1.0.0.gh.tar.gz 95190 BLAKE2B 0e2971100da4dde0f25714e32047a2c7263a96a34c85ac5e75a30c319b03df9b0040220e94811d4b9535009066f224425587350de76b8a96fe4f385b8704df5b SHA512 7120d89237a731f0f1794e13a4db56b339a5b80c33881f069c101b4c4380e45b615c8d43bc96a81ae5be35a69a879fcc03941996326100a07bef5d2e12774c98
DIST httpcore-1.0.1.gh.tar.gz 95484 BLAKE2B 1a029122485ca00e1a9d836cab0088e3331c7a0714ed01edfe992ab5fc7eea909f11f57a143e883d1ea614aeed70d5d03a998cb11507c8491c7bfaf5f60f9b7a SHA512 2ad177bfc4523f659e5cfac5d61c464b964192856e4c84b253e85ead47631f9aedee5248e962899248f7b745783a0bc746024310841cc844a78ba52ea1637c44
+DIST httpcore-1.0.2.gh.tar.gz 95549 BLAKE2B 92aa9a936d8c6933e1840ae50e6dfb70e61c756027a0448c2f0a5d270937342bd99cdb110aae152103c0d6c966e9288a22f7166a04dbb06dfb2a6f1bf1454d87 SHA512 6fc0c686b0b02b1e822550c18a7a90d2501f9d530598511877ee8cb09a0bdc4d56afe48cbb5fab5f8c1a12ea443055fe2a081b990fa4270f84db8197646b4979
diff --git a/dev-python/httpcore/httpcore-1.0.2.ebuild b/dev-python/httpcore/httpcore-1.0.2.ebuild
new file mode 100644
index 000000000000..777ec038f07c
--- /dev/null
+++ b/dev-python/httpcore/httpcore-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}