summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-07 10:08:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-07 10:47:05 +0200
commit64d3c059ea626c06c6b4ce777b2c9afa0dece9e3 (patch)
tree90d08579a3c699b0dca1eedcc9c6c68c351ec22c /dev-python/httpcore
parentdev-python/exdown: Bump to 0.9.0 (diff)
downloadgentoo-64d3c059ea626c06c6b4ce777b2c9afa0dece9e3.tar.gz
gentoo-64d3c059ea626c06c6b4ce777b2c9afa0dece9e3.tar.bz2
gentoo-64d3c059ea626c06c6b4ce777b2c9afa0dece9e3.zip
dev-python/httpcore: Bump to 0.13.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.13.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 81b4b14f7a26..8e6badc51ed0 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -2,3 +2,4 @@ DIST httpcore-0.12.3.tar.gz 57587 BLAKE2B 3c0e7a210b21e54564c4c6077fadf66344b887
DIST httpcore-0.13.0.tar.gz 58310 BLAKE2B 29ed4ad768088c6226ece27cb82e2a1d8df32eba4cf446015b43360c330ec65b433f571ac8e13e4b8f8994ff6e097ce5bf79ae1b9561d940298172c66d539153 SHA512 28ed65d3b3b30a62e3f198d98ae77a3cc26bd80250f10a506851433b5572a6fdcab38bf0d670caea94dec43d5b61de21a3ea967a445041536cad68eb98cc12bc
DIST httpcore-0.13.1.tar.gz 58538 BLAKE2B 4c0b681f96fd64d17bc1974bdb74486fd336f84b27eda450d7de630c9f5dc2012ca91d10c4d0bcdaa06ff0e60d524993ab784721e4ffb55ff2848d68ea9ebb29 SHA512 ba410bf61e820016b061a8cd5a30b227bb75a78e90465459b2ff67dd76b9de9120d3b2474f6d8bb54698f627bb8801f2da5b3d85a4a41a0c5330d6bba8e10a49
DIST httpcore-0.13.2.tar.gz 59043 BLAKE2B c534c304b238837486b8a61860553475c87363b43842c9dad2629673c1d30c2f906f31658f6ff75bd9354040c08453c3d4ffe8bdf53077ca993399b93d68a57a SHA512 b032d56bc5bf4049d02ca2ddfaf66615a1ac2f0723291f82f9104a0d7f09d5eec710f9e1ac2082fa1e83ef7fa6fe4f5a6c7c28d660abd6803a990094c952834f
+DIST httpcore-0.13.3.tar.gz 64246 BLAKE2B afc43122a5502770b6efe7052846926e25fa678dcbd5c8ddbcd806df36dcf684d94df12571efaab0ff1b657fef14d5d71dd902be5cbec12c61db13004d7fe5a9 SHA512 7ba6c2cb77c082bcdb8cdfad2bc17646ccc9348f49760150ec1070429f94913b2fb9eae6d3407b404581b48670b866bf11696453325dd70610bd700e94990450
diff --git a/dev-python/httpcore/httpcore-0.13.3.ebuild b/dev-python/httpcore/httpcore-0.13.3.ebuild
new file mode 100644
index 000000000000..65db85718369
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.13.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="https://www.encode.io/httpcore/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/h11-0*[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # anyio and trio are not in the tree
+ sed -i 's/^@pytest.mark.\(anyio\|trio\)/@pytest.mark.skip/' \
+ tests/async_tests/test_*.py || die
+ sed -i '/^import trio/d' tests/utils.py || die
+ # pproxy is not in the tree, the associated fixture
+ # must be disabled to prevent errors during test setup
+ sed -i 's/def proxy_server().*/&\n pytest.skip()/' \
+ tests/conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local skipped_tests=(
+ # Require Internet access or hypercorn (not in the tree)
+ tests/test_threadsafety.py::test_threadsafe_basic
+ tests/sync_tests/test_interfaces.py::test_http_request
+ tests/sync_tests/test_interfaces.py::test_https_request
+ tests/sync_tests/test_interfaces.py::test_http2_request
+ tests/sync_tests/test_interfaces.py::test_closing_http_request
+ tests/sync_tests/test_interfaces.py::test_connection_pool_get_connection_info
+ tests/sync_tests/test_interfaces.py::test_max_keepalive_connections_handled_correctly
+ tests/sync_tests/test_interfaces.py::test_explicit_backend_name
+ tests/sync_tests/test_interfaces.py::test_connection_timeout_tcp
+ tests/sync_tests/test_interfaces.py::test_broken_socket_detection_many_open_files
+ tests/sync_tests/test_retries.py::test_no_retries
+ tests/sync_tests/test_retries.py::test_retries_exceeded
+ tests/sync_tests/test_retries.py::test_retries_enabled
+ # Require hypercorn
+ tests/sync_tests/test_interfaces.py::test_connection_timeout_uds
+ )
+ epytest ${skipped_tests[@]/#/--deselect }
+}