summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-06 04:38:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-06 05:30:54 +0200
commit6d0ffb71d33c3640caa14edd57f14d45b9ade3ab (patch)
treed43d74728e74fe4854c983076121ee0e54d486c5 /dev-python/httpcore
parentapp-admin/awscli: Bump to 1.28.1 (diff)
downloadgentoo-6d0ffb71d33c3640caa14edd57f14d45b9ade3ab.tar.gz
gentoo-6d0ffb71d33c3640caa14edd57f14d45b9ade3ab.tar.bz2
gentoo-6d0ffb71d33c3640caa14edd57f14d45b9ade3ab.zip
dev-python/httpcore: Bump to 0.17.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.17.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 55002185dd58..b164e3e0fd4c 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1 +1,2 @@
DIST httpcore-0.17.2.gh.tar.gz 85086 BLAKE2B 74f748c0135cbd0551b3d1cf22b655e9d8e26f517790d08e9cb10f10cc7eecc09187e755e429fd9620f6f845be1abc3a7fde2a4d8ce557d57296d1777aaebc81 SHA512 429451323b31006eddae88b2f5575bb4b672206056d466e274f0667c185f196bedc06e82ed3a824836d56360004ba368370bca88656c3c998d61f7382c990296
+DIST httpcore-0.17.3.gh.tar.gz 91500 BLAKE2B 65e6ac917f215fb3c2f6651633db29cf58b7c936b1554102bb1c2e777a289527d44472c2b92fb7c62e7e1a812a1cf9573796051f90ea088dc37fcc2052dfe10b SHA512 41f48d32caa7d7a3456528404392a257927d047f0a1c733e2a68c0fec97c7454c7f8d7d1b6851c5722cfac292dfaa478a4033c656e66d389c81c72dee8e7a7d2
diff --git a/dev-python/httpcore/httpcore-0.17.3.ebuild b/dev-python/httpcore/httpcore-0.17.3.ebuild
new file mode 100644
index 000000000000..d875f7d31179
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.17.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}