summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-26 06:46:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-26 06:46:11 +0100
commitb2431ecf2f049ac7a405cfcc01232cb6692d92b6 (patch)
tree715add4081d629aa82a0244b0a683cbc5e628f79 /dev-python/httpcore
parentdev-python/zipp: Bump to 3.11.0 (diff)
downloadgentoo-b2431ecf2f049ac7a405cfcc01232cb6692d92b6.tar.gz
gentoo-b2431ecf2f049ac7a405cfcc01232cb6692d92b6.tar.bz2
gentoo-b2431ecf2f049ac7a405cfcc01232cb6692d92b6.zip
dev-python/httpcore: Bump to 0.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.16.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index 0280ae5cd981..822acee8b4a6 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -2,3 +2,4 @@ DIST httpcore-0.15.0-h11-0.14.patch 7087 BLAKE2B 08a7b1a155392637cea9b6d59d01fc6
DIST httpcore-0.15.0.gh.tar.gz 76220 BLAKE2B e9a346d4f77cde82be5a3eb468123ae453753e57b54382f0b2c60b16afd3433cba173d9a796df20d76edbd8b5bcf2d61c32302bdd30c8d587036b3ac6f0425fd SHA512 3c25630d582448e3c7d46176c8862e4d92c6c4aac954bfe46b06e26297b32f996db2e002a87c7187accb5bf4ef86e82d7f9051404bee651ce5254119571d0c95
DIST httpcore-0.16.0.gh.tar.gz 77020 BLAKE2B 0a6000c6e74204a8b90e32739344cca1e76dae73e53c6bee1d2bec16eb7aef11df761cf2cbee879f34a4995b5c8d0fc4a12bec23b07a58c1f06a06e2e1c4166d SHA512 28b6ba9f167f87ba8dadd3187248407c61c9770e27a1a281b6a0eb25e0a8966b3aa80587f00c8d92cdda44ffbe6f4af19adcecaa775ef59fa23492fa35be5323
DIST httpcore-0.16.1.gh.tar.gz 78091 BLAKE2B 21e5ad922c7190299336a4b0a7efc3689027b9f7208f7276526080460aca3a52c32b2c0db80cbae8d9a40e90aca27c03eed6f5e67a8b9d3d28b97e8bb655d7ab SHA512 a160a02b6c33cdedc1cea6b72cca7e8742ac97333b6d1a3931711f10e397d5e0ba03b2c191e0a7700a1ecd667cbcac4246ef29450da8472ebcc7f19602d8b39d
+DIST httpcore-0.16.2.gh.tar.gz 78465 BLAKE2B f028bc524dcf865b5213d4ff21dcfff525ac34d4dfa1301ebc56392f3082b3b76b6ec1da5e50a01c416cd09d53ad5edd5f2a6d6d4f9dd78e8a579812c0cebc36 SHA512 d11fe4f6a59e2dc1bce6724941db5978f0863f73e39786121f775d9c1702a32741de2cb4a0588fc907294d1b244713222cc57ef19a0d66e4075075c621f17d9b
diff --git a/dev-python/httpcore/httpcore-0.16.2.ebuild b/dev-python/httpcore/httpcore-0.16.2.ebuild
new file mode 100644
index 000000000000..621c94bfed43
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.16.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}