summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-09 05:00:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-09 05:22:32 +0200
commitd857f5d0aea606ee142d08532f2b658407d0e25c (patch)
treef349b0cde8b4ca603a0f1104f55750a9a4412081 /dev-python/httpcore
parentxfce-base/xfce4-appfinder: Bump to 4.19.1 (diff)
downloadgentoo-d857f5d0aea606ee142d08532f2b658407d0e25c.tar.gz
gentoo-d857f5d0aea606ee142d08532f2b658407d0e25c.tar.bz2
gentoo-d857f5d0aea606ee142d08532f2b658407d0e25c.zip
dev-python/httpcore: Bump to 0.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpcore')
-rw-r--r--dev-python/httpcore/Manifest1
-rw-r--r--dev-python/httpcore/httpcore-0.18.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/httpcore/Manifest b/dev-python/httpcore/Manifest
index a384658c70ed..38f359717ea3 100644
--- a/dev-python/httpcore/Manifest
+++ b/dev-python/httpcore/Manifest
@@ -1 +1,2 @@
DIST httpcore-0.17.3.gh.tar.gz 91500 BLAKE2B 65e6ac917f215fb3c2f6651633db29cf58b7c936b1554102bb1c2e777a289527d44472c2b92fb7c62e7e1a812a1cf9573796051f90ea088dc37fcc2052dfe10b SHA512 41f48d32caa7d7a3456528404392a257927d047f0a1c733e2a68c0fec97c7454c7f8d7d1b6851c5722cfac292dfaa478a4033c656e66d389c81c72dee8e7a7d2
+DIST httpcore-0.18.0.gh.tar.gz 94594 BLAKE2B 9602397bc2aa5941e9bfbffb7ba3e751c4ecac29a76dede6fa45f190ac7514f2e081cc67b781a8b6152c85ca3bfb051bdbc34628b95d05eba25a307e8877faa7 SHA512 3dc8114bf02226fc4ac87408163e599f4e9f70f9e5663c9eb7dc9a65b2b72861f3b19ed2f87e29ac90a8b85c5dc32a3fffdaf88e83b15df838fcbd89737b1c57
diff --git a/dev-python/httpcore/httpcore-0.18.0.ebuild b/dev-python/httpcore/httpcore-0.18.0.ebuild
new file mode 100644
index 000000000000..03a72f4ae1f8
--- /dev/null
+++ b/dev-python/httpcore/httpcore-0.18.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A minimal low-level HTTP client"
+HOMEPAGE="
+ https://www.encode.io/httpcore/
+ https://github.com/encode/httpcore/
+ https://pypi.org/project/httpcore/
+"
+SRC_URI="
+ https://github.com/encode/httpcore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ <dev-python/h11-0.15[${PYTHON_USEDEP}]
+ <dev-python/h2-5[${PYTHON_USEDEP}]
+ =dev-python/sniffio-1*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ dev-python/socksio[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "SOCKS support" dev-python/socksio
+}