summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 21:37:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-10 00:07:09 -0500
commit8b271aab0cbf692666da48a0f7958a4ebba6010f (patch)
tree51ae8af6f85904372436ddb7e8d5a1f44e760575 /dev-python/httplib2
parentdev-python/pastedeploy: 2.0.1 bump (diff)
downloadgentoo-8b271aab0cbf692666da48a0f7958a4ebba6010f.tar.gz
gentoo-8b271aab0cbf692666da48a0f7958a4ebba6010f.tar.bz2
gentoo-8b271aab0cbf692666da48a0f7958a4ebba6010f.zip
dev-python/httplib2: 0.12.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/httplib2')
-rw-r--r--dev-python/httplib2/Manifest1
-rw-r--r--dev-python/httplib2/httplib2-0.12.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/httplib2/Manifest b/dev-python/httplib2/Manifest
index aa88a10bd5e9..77519fa0ebc1 100644
--- a/dev-python/httplib2/Manifest
+++ b/dev-python/httplib2/Manifest
@@ -1,2 +1,3 @@
DIST httplib2-0.10.3.tar.gz 204500 BLAKE2B f71d679b42865bd8e56f708e71d475bfc6988267b07cf7af298ae7ba2c132a67fa04f54f36dfa0d222f86f421ade40724638fdc5840f340da0e8e1a717bb6cdd SHA512 d024986ffd577858017d7a8cfcae98a6cd04b8c89634ea302df4c1443eb2381cecca6ffbb631c9d4260335a3462df6d5604ec485aa591a05cb0231a3f6745aaa
DIST httplib2-0.11.3.tar.gz 215815 BLAKE2B 912d7cf56b941cc5ecaac23e16e20c17a31dc81b1ecb755cd3be36f0aaaf62302a760ca82104abb9052ee5c7d0c91baf04425303d124165085a06a20a66e5ba1 SHA512 e74be0ba945aaf5836ef14f4b8262e2be4b7f2a1df52b60f8ae7109d9727e117a69a8b7e4f524fb91997781af031a8a7c2112a7ab2b5d9f5c94b04a56aa04659
+DIST httplib2-0.12.1.tar.gz 218582 BLAKE2B 98c41a96b4e78897e803dbac3d6fedb25ad78f48d0b14ea29340f18da66be4622c7f0ae49acb2f4abca9542a174295d91aa21a6313b15501c4c1e590720a40bb SHA512 b083f0f5e22b384fd61eac428c1c60209702cf595762eadf6734afcf3cef6c3df8c7f2bedc5d782a4a6120a1dec51f910298f678c634c6b5e5d31348d9e10d25
diff --git a/dev-python/httplib2/httplib2-0.12.1.ebuild b/dev-python/httplib2/httplib2-0.12.1.ebuild
new file mode 100644
index 000000000000..0d4ac24b5236
--- /dev/null
+++ b/dev-python/httplib2/httplib2-0.12.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A comprehensive HTTP client library"
+HOMEPAGE="https://pypi.org/project/httplib2/ https://github.com/jcgregorio/httplib2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="app-misc/ca-certificates"
+
+# tests connect to random remote sites
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.11.3-use-system-cacerts.patch )
+
+python_prepare_all() {
+ chmod o+r */*egg*/* || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if [[ ${EPYTHON} =~ ^(python2.7|pypy)$ ]] ; then
+ cd python2 || die
+ else
+ cd python3 || die
+ fi
+
+ "${PYTHON}" httplib2test.py || die
+}