summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-21 08:49:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-21 09:54:18 +0200
commitdaa17b7c7f1ff4ab512c1190709c392c8da235a9 (patch)
tree857947861a19c5bb06e657d14e259ea204421384 /dev-python/huawei-lte-api
parentdev-python/blessed: Bump to 1.19.0 (diff)
downloadgentoo-daa17b7c7f1ff4ab512c1190709c392c8da235a9.tar.gz
gentoo-daa17b7c7f1ff4ab512c1190709c392c8da235a9.tar.bz2
gentoo-daa17b7c7f1ff4ab512c1190709c392c8da235a9.zip
dev-python/huawei-lte-api: Bump to 1.5 (or 1.5.0)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/huawei-lte-api')
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
index c48715730e1d..6140a382e39e 100644
--- a/dev-python/huawei-lte-api/Manifest
+++ b/dev-python/huawei-lte-api/Manifest
@@ -1 +1,2 @@
DIST huawei-lte-api-1.4.18.tar.gz 29701 BLAKE2B 0e242f2f2208646c9f3291dab8397a80934bce3757fb79b58fdcee389a087788962cfaea3350d7b95e53ff3e0f1fbefdf7ea6714266872fc1591848a4fb84462 SHA512 4750fcc84fff46c76f42715e6668d402b9057f8dd826276ad0682e9bac76742c86566794d4aaab7aa9ebf17d06246c4d4cc9385ee1fff9642ff5c995491fc646
+DIST huawei-lte-api-1.5.tar.gz 31741 BLAKE2B eded2f2ba04dfa8973a5ccd627996770b93e2509aeb2d0ff40dafc9a5ee0f6d242d032d310102297a1f56ee255b10f0e6e02c3a0ad687b6006e31ad8b53fb32e SHA512 f235664464abc23da85a36b17f356c7be65e686e06bbaba9aa06c728fa04ae5ab4fa32168c4fb2914a22472564d8f3365f9fe47f33e1892f923e6934dbd692b0
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.5.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.5.ebuild
new file mode 100644
index 000000000000..70850fbcf204
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="https://github.com/Salamek/huawei-lte-api"
+SRC_URI="https://github.com/Salamek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # https://github.com/Salamek/huawei-lte-api/issues/86
+ sed "s:'pytest-runner'::" -i setup.py || die
+
+ # make cryptodome-friendly
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:g' {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest