summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-23 20:39:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-23 22:28:20 +0300
commit090ec4a62029feab0ba039f1a18ddbac1afdc7b5 (patch)
tree1b84e19bae8166ffbbb6924029cf739ed0e141ae /dev-python/humanize
parentdev-python/uvicorn: add 0.18.1 (diff)
downloadgentoo-090ec4a62029feab0ba039f1a18ddbac1afdc7b5.tar.gz
gentoo-090ec4a62029feab0ba039f1a18ddbac1afdc7b5.tar.bz2
gentoo-090ec4a62029feab0ba039f1a18ddbac1afdc7b5.zip
dev-python/humanize: add 4.2.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-4.2.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 56452d90703d..e98f4c69b733 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,2 +1,3 @@
DIST humanize-4.1.0.tar.gz 73777 BLAKE2B fcbde90977ae9fcd706e423767b1d5617fd118ae8903283f4b307ee05a5adffb3bb68305e5d758b1860d37a37d22766127d84479d331a7ed05c83cd53e5b0829 SHA512 7e2d92ed44e773bd8a53d4b151e80949fda057d8f4a52003826efa9ec2a569360b76663d44c3d1239fd2ecdd5365357d3fac72a395d1c10d5207b4a27f248878
DIST humanize-4.2.0.tar.gz 75169 BLAKE2B dc590d296362be20f607282686e18df73e1bb07aa37459431d7ec1f74ff6611497811da974b7eb62cd791536268018460d9171eb65ed958af6f12f668b3ae2a8 SHA512 ac0a067320d4dc236d97a69a3019cf01ce87efe2cb98e758f516f90986352fe87d03bfa497d66a2a75e61152a35fd8fac827bafd926d6bd84c8f0d2366e5beb7
+DIST humanize-4.2.1.tar.gz 75327 BLAKE2B 1c36002a2a5d103bc1dae444d9d8a70c3983c778674d5c6aa3a76aa82dc9bd3bf39faefd1c3dcf8d0726b151dfb4f8d8247bb88fdc9af765f703edfb08226b8a SHA512 c84f797b01bb8bcc2e036496f0b727f9c21fe88148a6d90f73ddacd25f73059a46bbc60ef8c3bb81554db0c75f1ab9aa1e551d8473aecb40761e51b59580092a
diff --git a/dev-python/humanize/humanize-4.2.1.ebuild b/dev-python/humanize/humanize-4.2.1.ebuild
new file mode 100644
index 000000000000..b471878fc311
--- /dev/null
+++ b/dev-python/humanize/humanize-4.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="
+ https://github.com/python-humanize/humanize/
+ https://pypi.org/project/humanize/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest