summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-21 08:50:11 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-21 08:50:11 +0100
commit58b7e923678d444c1995f90de45d8fea7c124325 (patch)
treec06223b53401a425eff299d99d46ca8f41c17c6c /dev-python/humanize
parentdev-python/isort: Bump to 5.8.0 (diff)
downloadgentoo-58b7e923678d444c1995f90de45d8fea7c124325.tar.gz
gentoo-58b7e923678d444c1995f90de45d8fea7c124325.tar.bz2
gentoo-58b7e923678d444c1995f90de45d8fea7c124325.zip
dev-python/humanize: Bump to 3.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.3.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 4884437c0e85..a5d7c31df048 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1 +1,2 @@
DIST humanize-3.2.0.tar.gz 53976 BLAKE2B 2e9347418ffa103c6a66583136aa0c79bce669b48fcbc01bf482ba16659af14d4b4a88e78167e8013a8ede6467ed7b7f5eea8f46ed4234294a79b0c63fabd17c SHA512 448919e762e0ecc95f5a7158e0dd8bc028d173ee236be8e15fd0283741af037af1bcdc671ed83b0c16c1998dc0a70debf11cb1c349085530e458bc7aa2f6dde4
+DIST humanize-3.3.0.tar.gz 54639 BLAKE2B 7861a5e0403aa9ea047e39f9aa42fdfd7c7f38f295e93b9790f7fea3a86a57e33e65cb302165f1f962a46bf84238fc8b53b2e3e786eb1804b674dca97f959fae SHA512 a25bbaaa8cdd8fc0a7375637c19f91f892b33b8576e4c88b9adc431e976cb4f8937f1f98d71f442547626276c75cb6be445cac9b11b6504b6a444740df486faf
diff --git a/dev-python/humanize/humanize-3.3.0.ebuild b/dev-python/humanize/humanize-3.3.0.ebuild
new file mode 100644
index 000000000000..7bc5554aa175
--- /dev/null
+++ b/dev-python/humanize/humanize-3.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest