summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-09-18 10:23:13 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-09-22 15:11:52 +0200
commit66891be3579ad9e3b23be786627286757c2de38c (patch)
tree19c29bfd318a8c27f7dba9ad0103ded5a71f0608 /dev-python/humanize
parentnet-vpn/i2p: remove version 0.9.29. (diff)
downloadgentoo-66891be3579ad9e3b23be786627286757c2de38c.tar.gz
gentoo-66891be3579ad9e3b23be786627286757c2de38c.tar.bz2
gentoo-66891be3579ad9e3b23be786627286757c2de38c.zip
dev-python/humanize: add py3.6 and pypy{,3} to PYTHON_COMPAT and add doc support.
Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5729
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/humanize-0.5.1.ebuild19
-rw-r--r--dev-python/humanize/metadata.xml1
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-python/humanize/humanize-0.5.1.ebuild b/dev-python/humanize/humanize-0.5.1.ebuild
index 7d99b12bad01..cddd0815cf3a 100644
--- a/dev-python/humanize/humanize-0.5.1.ebuild
+++ b/dev-python/humanize/humanize-0.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
inherit distutils-r1
@@ -16,8 +16,21 @@ SRC_URI="https://github.com/jmoiron/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ sphinx-build . _build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
python_test() {
esetup.py test || die "tests failed with ${EPYTHON}"
diff --git a/dev-python/humanize/metadata.xml b/dev-python/humanize/metadata.xml
index abab48e71c89..1957b0b12307 100644
--- a/dev-python/humanize/metadata.xml
+++ b/dev-python/humanize/metadata.xml
@@ -4,7 +4,6 @@
<maintainer type="person">
<email>sautier.louis@gmail.com</email>
<name>Louis Sautier</name>
- <description>Proxied maintainer; set to assignee in all bugs</description>
</maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>