summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-29 17:48:31 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-29 20:09:41 +0200
commitad820211f5bc722b4f07ea928d8c34c776d6f9f8 (patch)
treee9530c9244e69bd7777098f5d52f07c08838e70a /dev-python/humanize
parentdev-python/pytest-subtests: Bump to 0.5.0 (diff)
downloadgentoo-ad820211f5bc722b4f07ea928d8c34c776d6f9f8.tar.gz
gentoo-ad820211f5bc722b4f07ea928d8c34c776d6f9f8.tar.bz2
gentoo-ad820211f5bc722b4f07ea928d8c34c776d6f9f8.zip
dev-python/humanize: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/humanize')
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.6.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 108137c04027..26d9f6fb7607 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,2 +1,3 @@
DIST humanize-3.4.1.tar.gz 56119 BLAKE2B 79f91e03b0c3ab1c645552ee3a0bf321e0ee620f5c0af827e44ba9995c9128638d1dc5cd80e4210de143ab55b39fb25e03abb4afaf5fa9a98973ef6c37d99b2d SHA512 d7e201717ee6b1065920faed3fa70f48c7b6acaf246a707126246d84f516fe7a14713bf4c488b18815907a0926b6cf505f106e15f17051f69756a50f50cea51b
DIST humanize-3.5.0.tar.gz 56651 BLAKE2B 05095fbdf7c55258bf3d01c73f47bf913e1fda3e6d8a2fcf666f4d70cfd6e437071140716b9f5b6a31c02c06da1d2df6f80d5d021c279d4f97f756f41f3c3bb3 SHA512 ca04d79533b08f1549cd530fec35352696b314d6d667476bf5506a482a4ff379fe6ae021a1f338aa6837877a90e57ce032cdc671b68be34dd52e0e41aad10170
+DIST humanize-3.6.0.tar.gz 62280 BLAKE2B 6472e332bbd4c8bd539b084889f280e56cb0b8fd3083c88b5f9fe313de734aa8876f6d9fb9b1ba3f9d6b110b5ee0d9af6881140c30fcf64c33364488f3c22033 SHA512 502ad941d9ff97677f9a6da7194ff2cddff6c4e852b84339a17eb13d71d34701b4c39c05607314a0d06c6634b5e5e12444bc97f0ae35d715611f8dac3eafe623
diff --git a/dev-python/humanize/humanize-3.6.0.ebuild b/dev-python/humanize/humanize-3.6.0.ebuild
new file mode 100644
index 000000000000..c806307de9e9
--- /dev/null
+++ b/dev-python/humanize/humanize-3.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest