summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-01-05 02:21:58 -0500
committerTim Harder <radhermit@gentoo.org>2018-01-05 02:21:58 -0500
commit62e74b60a6b85c051c6e1ccdd4077f9e9eb92d8f (patch)
treec3f186dcbcc46a9e26bef2d8f566e998da659292 /dev-python/hypothesis/hypothesis-3.44.7.ebuild
parentmedia-libs/exiftool: remove old (diff)
downloadgentoo-62e74b60a6b85c051c6e1ccdd4077f9e9eb92d8f.tar.gz
gentoo-62e74b60a6b85c051c6e1ccdd4077f9e9eb92d8f.tar.bz2
gentoo-62e74b60a6b85c051c6e1ccdd4077f9e9eb92d8f.zip
dev-python/hypothesis: version bump to 3.44.7
Diffstat (limited to 'dev-python/hypothesis/hypothesis-3.44.7.ebuild')
-rw-r--r--dev-python/hypothesis/hypothesis-3.44.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/hypothesis/hypothesis-3.44.7.ebuild b/dev-python/hypothesis/hypothesis-3.44.7.ebuild
new file mode 100644
index 000000000000..4869c0b7b9eb
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.44.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis-python https://pypi.python.org/pypi/hypothesis"
+SRC_URI="https://github.com/HypothesisWorks/hypothesis-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}-python-${PV}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}