summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathy Vanvoorden <mathy@vanvoorden.be>2016-11-04 09:47:00 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-06 17:46:02 +0100
commit6137b61e7d077d4dd1ef8ae6b98d706ae09fbbc6 (patch)
tree93ffe07ba29a90232409a622f099783439bf284f /dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild
parentapp-portage/flaggie: Update URLs to GitHub (diff)
downloadgentoo-6137b61e7d077d4dd1ef8ae6b98d706ae09fbbc6.tar.gz
gentoo-6137b61e7d077d4dd1ef8ae6b98d706ae09fbbc6.tar.bz2
gentoo-6137b61e7d077d4dd1ef8ae6b98d706ae09fbbc6.zip
dev-python/hypothesis: bump to 3.6.0, eapi bump, fixed dependencies
A new version was released that removes the dev-python/uncompyle6 dep introduced in 3.5.3. This also means that the KEYWORDS and pypy3 support that were removed in eea41c4ca5bcd27af35f3276459567b91e4a34e7 can be reintroduced. Also 3.4.2 no longer needs to be kept in the tree. This package has a dependency on python being built with sqlite support. It isn't obvious and only shows when other packages (like cryptography) use certain modules of the library. Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=593824 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=579514 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=580540 Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2737 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild')
-rw-r--r--dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild b/dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..8d93829b49ea
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.6.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis https://pypi.python.org/pypi/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*')"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}