summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-22 17:49:02 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-22 23:45:38 +0100
commitd44eb7bb2e9e2c520b95685acc3000455967f58c (patch)
tree2ddb7b855de3368141b506fe88fbe1ae7b86dcea /dev-python/hypothesis/hypothesis-3.6.1.ebuild
parentapp-crypt/mit-krb5: respect USE=nls (diff)
downloadgentoo-d44eb7bb2e9e2c520b95685acc3000455967f58c.tar.gz
gentoo-d44eb7bb2e9e2c520b95685acc3000455967f58c.tar.bz2
gentoo-d44eb7bb2e9e2c520b95685acc3000455967f58c.zip
dev-python/hypothesis: Bump to version 3.6.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/hypothesis/hypothesis-3.6.1.ebuild')
-rw-r--r--dev-python/hypothesis/hypothesis-3.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/hypothesis/hypothesis-3.6.1.ebuild b/dev-python/hypothesis/hypothesis-3.6.1.ebuild
new file mode 100644
index 000000000000..8d93829b49ea
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/DRMacIver/hypothesis https://pypi.python.org/pypi/hypothesis"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*')"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}