summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-05 10:06:33 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-05 10:06:33 +0100
commit06d3ba4612ee3a24fe1e115616957afac820ad47 (patch)
tree44347725ca7ca65c58c190fa6926a6dbbbf1c23b /dev-python/hypothesis
parentdev-python/phonenumbers: Bump to 8.12.14 (diff)
downloadgentoo-06d3ba4612ee3a24fe1e115616957afac820ad47.tar.gz
gentoo-06d3ba4612ee3a24fe1e115616957afac820ad47.tar.bz2
gentoo-06d3ba4612ee3a24fe1e115616957afac820ad47.zip
dev-python/hypothesis: Bump to 5.41.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.41.5.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index c1972bd53a0e..567b7ca5a4ea 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -7,3 +7,4 @@ DIST hypothesis-python-5.41.1.tar.gz 9095771 BLAKE2B 29c5c091f4b827d1f1e6276d040
DIST hypothesis-python-5.41.2.tar.gz 9095799 BLAKE2B c1743f2e9872cefdd82dd79b60f78ae02bb975be2156bf7c05054627ca8386092588721450dfe14954129e46ea3556b78f7784102640d84368bdc98af2980b04 SHA512 712a6b3a007e4b354e9ed2137b7dd53652abbbf0b324467ce540ca886fb956eae5d00f83cbc1c9b1799a4a3abc64f4d26d9aed85d5fb689e904e1125b87b88eb
DIST hypothesis-python-5.41.3.tar.gz 9095982 BLAKE2B 3a1b7052b3f71d1f8139101d16f2f74c2d434514a201b7e04e5452ac2c5fbe7288d592c0020769f3a48f73347cdce53f507ab65db7bfb4f3823d0f7997e48058 SHA512 974dee6040222fa55729257cea4e3c4c049625a2a5dfddbc12667dbd58dfe31718474ce8e9de81519e998c7a0c8ff01920e0aa2bca9fb7100754e985177f4b69
DIST hypothesis-python-5.41.4.tar.gz 9098296 BLAKE2B ef471172039251129d03faea722fc190135ed3d2e94a9bc6d4ad4f9676bc819e641dd0c893352168425ce987128e73d8844f622e57a7c161d33f75ea0f4b7312 SHA512 215f2e4479eca10d8ca590ffe0623f8994c7061fddabfe2737d0f3bba2f403042ad8e75730361417a1c9c32d3e261c8daa84032f6963ef6526e6b0067a156658
+DIST hypothesis-python-5.41.5.tar.gz 9098660 BLAKE2B 6caa742d34a3a2aeb6c6fdec3f8772e5221e1d0b2becc1362b657d383387f2a1152756222cfe86ffbb3e23a53e395050a16325d74ec9e03822a5c0020505b38e SHA512 b220a48e5746bacc6fa257f79feed0dc2c0a9f66862aba74806fb1ac3d06f380620410c9c46c377c50e4fa7c3171d5b31ce2759e7a3e0e2abd0920b237242dd6
diff --git a/dev-python/hypothesis/hypothesis-5.41.5.ebuild b/dev-python/hypothesis/hypothesis-5.41.5.ebuild
new file mode 100644
index 000000000000..7cd8e4bcc527
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.41.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}