summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-06 09:01:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-06 09:22:42 +0200
commit28b4eae0dc2165d62f58e3cd3f5303d505ac1d25 (patch)
tree4c519eb568002d3b7bedd694216cb515b9763532 /dev-python/hypothesis
parentdev-python/sphinx_rtd_theme: Bump to 0.5.2 (diff)
downloadgentoo-28b4eae0dc2165d62f58e3cd3f5303d505ac1d25.tar.gz
gentoo-28b4eae0dc2165d62f58e3cd3f5303d505ac1d25.tar.bz2
gentoo-28b4eae0dc2165d62f58e3cd3f5303d505ac1d25.zip
dev-python/hypothesis: Bump to 6.8.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.8.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 6e6905e38ceb..348c411865e4 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-6.6.0.tar.gz 9117847 BLAKE2B bb88ebee9db53f1c5753730d04e5
DIST hypothesis-python-6.8.1.tar.gz 9119495 BLAKE2B 4d98e30a04f652af79dd49e921b856124a312b63f087a6fd200282e9b0a0cd6fcad1a42a6008406bc347f21bf9cd6c5ff2db79d013987281f59365bd9d91550d SHA512 2f25e994438479b5faa15b2038146ab385445bf2722b0951ff55f324b074248d7322c4c6f3e9c659c18d0aa94150eea4c6567a7ac24debf2de4b32bab37a4dcc
DIST hypothesis-python-6.8.3.tar.gz 9120421 BLAKE2B 9511f63aafe499316750ec8a993726d4e8db87b42fb772cf79cde1be18b23e99f55c1a2638f3ee7afadae5f323792322cf87b747ac428146fea2abc92793f8f5 SHA512 83660978dc4ff49a04d7167994821a18c769039c49dcbc515b28591651bb9ab2121e3a7267cb20281efade85003a5808e0898fda5dfe1e4be563a03d4688085c
DIST hypothesis-python-6.8.4.tar.gz 9120762 BLAKE2B 00c6348c924252207cfca30babb2b281b70067478892ec154ef6fa40f87d5a1a4d7d4047eb2cb9f3e6b8cadee240f3475c2dc912f393553b35b0a6c71cf0ae4b SHA512 bb1c14aedf51bee4394c6b27d9c92d5c13b1d1e690608efff0cb68ae3ae7e8a078c99c10d0f1c4a6977430c8ebefea083af1be28f1535f93e320579614c9f46c
+DIST hypothesis-python-6.8.5.tar.gz 9120852 BLAKE2B af15d2eaf0dbbd5d031c88af911bc9c490ba0cef0fa8a903747dbac93e8be72defbb65e7d41b354e713d56d956a7f09e6652390a771c4fedad3b0caf5830468f SHA512 ed1c67e7ffdd9cdf7864c1b21394419151936ee23bf2c3bbb9e5502f3184b092eeada97cf1ae5dfae857e268461662f2cf264cdfa76b146cddb824e01eb06e17
diff --git a/dev-python/hypothesis/hypothesis-6.8.5.ebuild b/dev-python/hypothesis/hypothesis-6.8.5.ebuild
new file mode 100644
index 000000000000..75d02aad2bd3
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.8.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}