summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-03 08:41:47 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-03 09:23:56 +0100
commit37dcea8e7a802bd08d3525ef23702b672da8d548 (patch)
tree1f42d3a3c34c030d1635dd741e450ed512ab33b9 /dev-python/hypothesis
parentgames-simulation/openrct2: drop old version (diff)
downloadgentoo-37dcea8e7a802bd08d3525ef23702b672da8d548.tar.gz
gentoo-37dcea8e7a802bd08d3525ef23702b672da8d548.tar.bz2
gentoo-37dcea8e7a802bd08d3525ef23702b672da8d548.zip
dev-python/hypothesis: Bump to 5.41.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.41.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 23850309dad0..4bc76e13ebce 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-5.35.4.tar.gz 9084892 BLAKE2B 5545f2b1f3e97eafb4c83d7918f
DIST hypothesis-python-5.36.2.tar.gz 9088227 BLAKE2B 578c28d045f3b3f288d43765d556f1e7bbde661684b71f6379df3eba516d8ece86f31a38a414e676532f6ecb8a1ee69ac77d207a8637eaef8b9a86584d3292eb SHA512 d6792d5b9f60aea6181018c69eaa12982ef0ab353bff3f46bc987a4633a15b655ed04ee8ae3aca7dbd9e23cf5f85e4a95e455082f4035e246342b72e2dafe258
DIST hypothesis-python-5.37.5.tar.gz 9092380 BLAKE2B b5bf9f5c5bb1002154ea6041c38b727e926ae65641a05ddd2bfe919fdb7b6457963ddcc5bf1d57a929c57a3912b15a13c52b4568708348f4f308146cf64caa61 SHA512 ddf2db9d8f9318b0b3ae872fdfebbc4ac8376a86816e7c9a0350738a68a4e3adbe41aaf19a8f54471f551542f3252172cc34f5bc140483989ef8c04c5735f044
DIST hypothesis-python-5.41.0.tar.gz 9094817 BLAKE2B 3025caf9a0ccba19abfd12273edefe1db825a40615a378fb076e8d3ba96bfecc64ec23be6ef72b6fcd89d7d6b5c94bbf12abf3212e4a521a21def892b0d95a56 SHA512 76a0147d36179368d62a3d9e6f9f27effa903476fa0cccdba4574937c470bbfd020daccf9b3df73f457b543b6a94ce0858fe4d9abdfe9c16a8c49858c8bc0e92
+DIST hypothesis-python-5.41.1.tar.gz 9095771 BLAKE2B 29c5c091f4b827d1f1e6276d0401c1a673077304b3ee8b0252536c3eeda066a4cfa764856edb222ba6cbaebb424b08aebc8d8ec00c5e0d445774b1c62ed98593 SHA512 b1f02e32e6c5bdb6ca0a338901715508a03d2734898c673c5b3a5b25dee34922d7fbfcc2534b0c658d003d5de3e97abecb5a9b4f00ada0cc85c457b4b870a873
diff --git a/dev-python/hypothesis/hypothesis-5.41.1.ebuild b/dev-python/hypothesis/hypothesis-5.41.1.ebuild
new file mode 100644
index 000000000000..b817839fd0ac
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.41.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}