summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-02 09:16:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-02 09:30:17 +0200
commit7393e697ea9daad0a151b451993188168e965fe0 (patch)
treef09e2f38ede45517f1ffd95f8232fa19c7658db8 /dev-python/hypothesis
parentsci-visualization/paraview: add python3_9 (diff)
downloadgentoo-7393e697ea9daad0a151b451993188168e965fe0.tar.gz
gentoo-7393e697ea9daad0a151b451993188168e965fe0.tar.bz2
gentoo-7393e697ea9daad0a151b451993188168e965fe0.zip
dev-python/hypothesis: Bump to 6.13.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.13.11.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 93a28dbbd8ef..3682d71caa6a 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,6 +1,7 @@
DIST hypothesis-python-6.10.1.tar.gz 9126246 BLAKE2B cc8cb3436d1de5d3d65a13cb5edefdbaae8bf9daed296eea9111ac46c002c34f43119f10b2ab1f45c5cbca5fe46d00738676290eb0e8437f2c10b5926d9e0915 SHA512 586b7f380cb850089f7d5321f11da92ef4a9b80e2ea925103e29c1f6c6c9da0a2a899a1a45ce77e0a40073f147561bc4fcbd5cb2ce77a9c0c65f6f64dfe4b716
DIST hypothesis-python-6.13.0.tar.gz 9128293 BLAKE2B be618d42639602bc6617f8b5e9374812298e9d6150b6510a8060ca7c489ea69f1d6bd2cf9322c325c9bffc3c3f886fb4a4fb038159fa2c81920541ac4cb668cd SHA512 66fd6e7842b7b257c92cf756db4cf97bfb64006c89e3e58cda154ebe9345302f0264297df8d9de0685033a0f4e43909d65e76495689a8ded9968ecda586b668c
DIST hypothesis-python-6.13.10.tar.gz 9132876 BLAKE2B fb9b48465fd6e6ce08423384753ef3149aac6e2b57230f44119ad685c530ac68fac0b1a1925f2ab98586265055151e9564fa287262b06aefe68c2a78d8b3ae4d SHA512 f166a025dee3ec31033d8f8a3909e6f9ee4b2e14420ae41777a41163384502cfe9f20632fb134e38797817ee19972a7068e4233e64417fb4cf5af51427a1963c
+DIST hypothesis-python-6.13.11.tar.gz 9133504 BLAKE2B b9cb54dc05aafd57424a2f9fff097a66e3ba5e55408f8a4587eb7aee079f1ad494e3a9cc18a7797c09fa4444715290dc49c58b98e722dc0722d8cad0d6cbbe0d SHA512 9cb8ce31a7062ab98db829300c1f68e1e24bf02a39ebf4ffbbf47554741dd0bdb96edd69aa7a360570405ca85b1fd7956eb26c5b9a6898f6f8f6f79177522bf6
DIST hypothesis-python-6.13.2.tar.gz 9130008 BLAKE2B 3ca5c306ac402002a1435b8ccbc034f2a7acf1553eb6095e0394ff1ddf778f47ef6f72359cb5219db924edc18623b22732b4a94bd7c269217ec632b8d59adc1c SHA512 8c7e1a5de011ef66f5105009aa82f2b23ff36f0b0906554ae65e2e55e10c4df743c894b6264002c86bae3fc5e1dd7ded7e913f0866ed725e1afd4c9f54022b7c
DIST hypothesis-python-6.13.4.tar.gz 9130435 BLAKE2B eeb78cc647df49ea11fb0e0f4d8412e20095e7c33bb0601dcbaad2b9e9929423729b25b1bfbf2a27b05e87ae38ced4e9aeba5bae4de76cfc81aae2d073248de0 SHA512 93db99bdbe408ddbad4baf983b00b3e7624fd28d15a0d4c1453437328a51b0733db13e3b7b04b40bc60aa05e2e8364ce5b186d81a2d33e50b49f5a406fec95d6
DIST hypothesis-python-6.13.5.tar.gz 9131314 BLAKE2B 3de7ba681ab9c0907920ea7ad562a4434f06009a7bced47b98bf46da5d15aea35085350f4aca24fd41ba9fd14957e4de1d56092d49e757ea60a1575f59371add SHA512 06765607be1a49d92382d426105021ed9dca91c5b41674ba45f0a29ce7cb06537edf706ea7305300f9aae7d8c9b1827bcaf807e3c4aece9594a55b3c0122c622
diff --git a/dev-python/hypothesis/hypothesis-6.13.11.ebuild b/dev-python/hypothesis/hypothesis-6.13.11.ebuild
new file mode 100644
index 000000000000..22d9efb5231d
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.13.11.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3_{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}