summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-15 07:59:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-15 08:31:59 +0200
commit7cb0f57c8e837bd08c88cfdfa9378e9e7fa5c339 (patch)
tree9014c846ada60c46bd548566818cce07e9bd777f /dev-python/hypothesis
parentnet-im/gajim: Bump re-adds plugin installer (diff)
downloadgentoo-7cb0f57c8e837bd08c88cfdfa9378e9e7fa5c339.tar.gz
gentoo-7cb0f57c8e837bd08c88cfdfa9378e9e7fa5c339.tar.bz2
gentoo-7cb0f57c8e837bd08c88cfdfa9378e9e7fa5c339.zip
dev-python/hypothesis: Bump to 6.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.9.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 6a36410fa85e..ba00d93d4825 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -3,3 +3,4 @@ DIST hypothesis-python-6.8.1.tar.gz 9119495 BLAKE2B 4d98e30a04f652af79dd49e921b8
DIST hypothesis-python-6.8.9.tar.gz 9122168 BLAKE2B 2568dcfcbc7182071247d0b7d978abf2184be4583937a42568c3e199eac6ce538adb7b3687747979fc6ab9da1e61088db7d1a01294982e75cb04992cdc10537a SHA512 4dc3884e2487f27a3b6b362e04cecd281f9072fdd2e8e91738899baf589d6d48df9eeacb9a158251c20b210d1190b78eadd191aa95f151023bd81091131dff66
DIST hypothesis-python-6.9.0.tar.gz 9123041 BLAKE2B 5c9a4d1bed02417dd35e67f7f8e63accc7a9c071fde03b7c38b835945605377d8898fbc760fa8149e8476beb247ce19ec946f5365065dfa66b2cb52381760373 SHA512 8d63b22ec3ac9418dde758f70f2a8b65b455cffa32fbbf1fc99c2e64ca40f73436ee9eddea7ada34d8d68a41e88b50d54166babee9869fc03b32926bd85a4507
DIST hypothesis-python-6.9.1.tar.gz 9123088 BLAKE2B 6a960622fc14d507d5ac66737b88e7b7184c827f31c505797be33766ac8d1721191e48334b58d1d73ef1058eaf94d88ef9d7ddf256948180a12c707b6963d1de SHA512 ad5f18ecbb0376b04eb26f58ad2b72ae6789029bf89f36d4880e5212a4cf7d669a048bb8d4f0bdeb0f5c1f1cc053d054d60235224f5154803fd0319d7b140b3b
+DIST hypothesis-python-6.9.2.tar.gz 9124848 BLAKE2B f1d13f37ee2c9fa4d2716e6c4df412cf652704c1fecda575be2959cde10c9e8b9e54b4a772bda4f1c476936817e6d47d8c17880fa13714daaa9e7b7fd0eca56d SHA512 c209e921e89b5b5863e7b103462cf34a0fd5d06c373c4d880b2aafd8b9521fcd95f58cd00f55eff81804352721b1114f208ce0e19f9142783834e93867ba336b
diff --git a/dev-python/hypothesis/hypothesis-6.9.2.ebuild b/dev-python/hypothesis/hypothesis-6.9.2.ebuild
new file mode 100644
index 000000000000..75d02aad2bd3
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.9.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}