summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-07 11:37:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-07 14:49:35 +0200
commit8962af0b6b96a7ae2b0dbacc00b79d7167fac68e (patch)
tree918b481be21e13a2fdaba6888ff0db5765066703 /dev-python/hypothesis
parentdev-games/tiled: version bump 1.5.0 (diff)
downloadgentoo-8962af0b6b96a7ae2b0dbacc00b79d7167fac68e.tar.gz
gentoo-8962af0b6b96a7ae2b0dbacc00b79d7167fac68e.tar.bz2
gentoo-8962af0b6b96a7ae2b0dbacc00b79d7167fac68e.zip
dev-python/hypothesis: Bump to 6.8.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.8.8.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 74ad838596b6..35fcb81cb69f 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -6,3 +6,4 @@ DIST hypothesis-python-6.8.4.tar.gz 9120762 BLAKE2B 00c6348c924252207cfca30babb2
DIST hypothesis-python-6.8.5.tar.gz 9120852 BLAKE2B af15d2eaf0dbbd5d031c88af911bc9c490ba0cef0fa8a903747dbac93e8be72defbb65e7d41b354e713d56d956a7f09e6652390a771c4fedad3b0caf5830468f SHA512 ed1c67e7ffdd9cdf7864c1b21394419151936ee23bf2c3bbb9e5502f3184b092eeada97cf1ae5dfae857e268461662f2cf264cdfa76b146cddb824e01eb06e17
DIST hypothesis-python-6.8.6.tar.gz 9120971 BLAKE2B c172fae93e28853e75c1a9cb4922ff9fef8100460c9d4b4963df47c252794a95eb24a8f09b386c52033103a897417aa1e210d4fcc2f6f60c5eb8aede3e8aeb09 SHA512 67a614fdfb92128a399b88ceb6a4791a1d2316179c6526f084bcc60dad2fac3172443307ebfe28f729ca4fcd150576d27cb7da86c937708943c74071ed3b638f
DIST hypothesis-python-6.8.7.tar.gz 9121168 BLAKE2B 87f0eafe558b9b87e69bbe5e5ee84ce8afc9cdfdf10bd2aa139ab3b334936ca7882367bcf18bc708a9ccd23a99c4a6abe8db4ca0a3d1ba50c033e5cdf7cbf70f SHA512 9b35d829a1b453a64eb17bd11a8981e8bf8e7aa99a8e59d9dd30c0fde98db1aaec36fac64ad2c9e319374240a7e6b612c01bc54401ef03112595630e6ff9286b
+DIST hypothesis-python-6.8.8.tar.gz 9121704 BLAKE2B 3c9aaf8e8ce9de4329a38bbbc098a51f0a05704e6166ac1022de76a0679302483e73c62639318ed4b7504f7a9f51ceb809e40d36049e9911677238543da6743f SHA512 8f9f6b738b43974263ff17bc166cdc1ebb092278007d075e9de2aa305315893f4201f800c926d40f0cfb03af514116ece69fb6082a706493b5a807a989e588ba
diff --git a/dev-python/hypothesis/hypothesis-6.8.8.ebuild b/dev-python/hypothesis/hypothesis-6.8.8.ebuild
new file mode 100644
index 000000000000..75d02aad2bd3
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.8.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}