summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-10 08:11:33 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-10 11:38:39 +0100
commitb58e4b28972a4b0a6626a47d469d73e3bf2543f8 (patch)
tree1fd8b1392e49a9e45a0c8c306f3c675a0eaf4412 /dev-python/hypothesis
parentdev-python/wcmatch: Bump to 8.1.2 (diff)
downloadgentoo-b58e4b28972a4b0a6626a47d469d73e3bf2543f8.tar.gz
gentoo-b58e4b28972a4b0a6626a47d469d73e3bf2543f8.tar.bz2
gentoo-b58e4b28972a4b0a6626a47d469d73e3bf2543f8.zip
dev-python/hypothesis: Bump to 6.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.7.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 00849386e646..cbf032102602 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -5,3 +5,4 @@ DIST hypothesis-python-6.4.0.tar.gz 9112974 BLAKE2B bb2312e1ae838e9a58741709f5d5
DIST hypothesis-python-6.4.2.tar.gz 9113516 BLAKE2B 115f16b4e9a4fdc4b39942cb593dc397066c556862cb79baf3c9d9c0c9d1fa46e1e855b91c73d8f93135e9582f6293d896245fbfa31bca667cb522f1d4955adf SHA512 bcaf876c197f196f27936fd6b5294cfed5d0db2f528ee95b9ebf6ae429a41dccddfd6fd66eebf8e5ad7ac512d8ec20f1878a6ded9d4c10013b732262c9454799
DIST hypothesis-python-6.4.3.tar.gz 9113616 BLAKE2B f3761a22b574edc0b001a25c836c3a845fb3a1396dbc4afc2caa1f31870793cfca8646e6b9b45386e835fce97b9bc68226018c50675931e48968e9502ad41844 SHA512 010d140538bd6a361326d00bf38a50ffbbe08adc55cc7597cf69563b5d028335493c1925bcb91f618afd87f4d754e8109776be89f229e8b25b91510fbf64d7bd
DIST hypothesis-python-6.6.0.tar.gz 9117847 BLAKE2B bb88ebee9db53f1c5753730d04e5dfe6a39ac4c5f7d534778b22b813ba188a55de6ad8a34f611f7863d1c3287be39ed7e10981e9d6ed8d8dd106688f154c3a49 SHA512 a446b4a11c6ee013225bfcd58e26efc6c9d867545d9bcf90a19468cb01fc5e2c5a7280ff9a80d4a1adbfe06dd155df6152941d5f53869d85e1d259e68a33a5e2
+DIST hypothesis-python-6.7.0.tar.gz 9118149 BLAKE2B 5c9601e6ffd9f2e20b518fdfc30f74ace1ee906604fca35c942a59370349c1166a1fd229de0bf5d3ebbfc1851fb59f92be65b112aeadc3bd10d4f628e3648e6e SHA512 fd57845f696117eb5d97f533443c60446adb95eb4dabc772c84eed268c2942001fecfc1460b42c2a83fdaec88176ff87a881f925a6e6ab5485b44f0878054d2d
diff --git a/dev-python/hypothesis/hypothesis-6.7.0.ebuild b/dev-python/hypothesis/hypothesis-6.7.0.ebuild
new file mode 100644
index 000000000000..f1a7844b5d55
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pydantic
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}