summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-03 08:14:52 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 08:14:52 +0100
commitc1347842eb0f28546576bd4ebc0210a80a4511d5 (patch)
treea88d27599df8c8283133a64423ead4b18232d7ce /dev-python/hypothesis
parentdev-python/miniupnpc: Bump to 2.2.2 (diff)
downloadgentoo-c1347842eb0f28546576bd4ebc0210a80a4511d5.tar.gz
gentoo-c1347842eb0f28546576bd4ebc0210a80a4511d5.tar.bz2
gentoo-c1347842eb0f28546576bd4ebc0210a80a4511d5.zip
dev-python/hypothesis: Bump to 6.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.4.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index dfe32f46171f..f5cc62663b6c 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-python-6.1.1.tar.gz 9107792 BLAKE2B 50d3b284f0ab1b7c1a25fbf1488b8fea74c66aaac07d58e3271f187e54579011311ef3c20cf5525e84058382c516e6cf1495201e8b6fbd45fe28309a25fda0e0 SHA512 7d6ef548333b860dd868a9aa2a220191c237ac8e843cff835f423332fa561377ced29a9703cf0a49c76594a986048c1b1a1b8df5b38b2848410cfd7708168d58
DIST hypothesis-python-6.2.0.tar.gz 9108590 BLAKE2B 73a6b71c68aec1ec51f791187bbe5be679d5e3b4da9e66745767dafb109d298b0c61bd461ed838a0c75884d155fb408bddebc75d1cf887629da5cf5d6b053e03 SHA512 b249124f90d1d68aa6e106965b0ae78e37f095be0adc1833895f0895357d46c907074e2abe458be566708ba006b6c4375908b40ef89d52300fd41ad63abc2e52
DIST hypothesis-python-6.3.4.tar.gz 9112374 BLAKE2B 78867f0ff142d6059a20c437c3fab333de06eff5247d93c1e70f75d801e54984c20da01322b7d4d4999cb30f2c59c6e7cf955fe60ecc0e90b452b8ddf6b6f2ff SHA512 7baee8758d86afbb0a8a16e18b2f14d3870ee2f5623857fc691ca1afc7f0c6555b367fbe758ff02c08af492b4569ef2aeb8d61bf3bd91ac458312a43b02d02f6
+DIST hypothesis-python-6.4.0.tar.gz 9112974 BLAKE2B bb2312e1ae838e9a58741709f5d55d9593991c2600330f4917c8e8f86eb8219a0826e87aa810ccfa731e5a14f1d0985cb3342c73ba5b8ad5d8e01419689e180f SHA512 2899557ff872b45347f8865ff9bf07da97e2bfc3f4827ead2d4b0648c664bd9ef7ae3d48e5f5158b4dbb2d5063831ae8a1a7ef0ac97f2ae21318c6198850865d
diff --git a/dev-python/hypothesis/hypothesis-6.4.0.ebuild b/dev-python/hypothesis/hypothesis-6.4.0.ebuild
new file mode 100644
index 000000000000..46ee7df74d3c
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.4.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}