summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-18 03:35:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-18 03:35:02 +0100
commitcf2b1aaf7b19badb8b0dc63441741cb0a99c4cf4 (patch)
treeb2ad1291e414624e87c030938ca879b8c1b41671 /dev-python/hypothesis
parentsys-apps/tuned: drop 2.20.0 (diff)
downloadgentoo-cf2b1aaf7b19badb8b0dc63441741cb0a99c4cf4.tar.gz
gentoo-cf2b1aaf7b19badb8b0dc63441741cb0a99c4cf4.tar.bz2
gentoo-cf2b1aaf7b19badb8b0dc63441741cb0a99c4cf4.zip
dev-python/hypothesis: Bump to 6.98.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.98.7.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 21dad185668d..6a6f1d469144 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -10,3 +10,4 @@ DIST hypothesis-6.98.3.gh.tar.gz 9438865 BLAKE2B 7a15ec4debd2a93974aca75aad9b7b1
DIST hypothesis-6.98.4.gh.tar.gz 9438902 BLAKE2B a5c560711448c301665a9c9d2f6106996fbf76d1fc3c3e8d67e053c94a59f462cb57ddb890b1dfb0bdd3569e1e6216d5fd4bcab10adf0ba0499caf84efeb3b25 SHA512 3f4496f48b3002f33a9324509463a4fbece7967f203a9b4a7e1a5bce557e296d0b335437fa590477e8e669b551618cd83fad2bc2478c443772399467f17988f7
DIST hypothesis-6.98.5.gh.tar.gz 9422518 BLAKE2B ff79d5ddad7d1474ccc536dba4222e8ba19a5066011e532384a7b1e686b44a2e4bd48df107b6be868e40513ee691dc3d8d401ac22109f058a948c0eec1d5266a SHA512 c77714986451eb9992254734b5302979ea51e5baae769e57a1076dd770abfe7c61ce38be865552d4961d5a6f2ae3d7325888404265e92a106f2c2cdc177f624d
DIST hypothesis-6.98.6.gh.tar.gz 9423503 BLAKE2B b2f3f0be0767d23db33dc87a3adef42d26b15e09d493fa1be8ae817bb316691946eb97876d66e67ee8e78e9023a8b2ba977e19878d3457d8ea4a28a9b1df4d05 SHA512 435b41651935f25264126aa13c3c15801ec384f30b6e6f701e6eff29f07dd867eaed0eaca9be4182f043dac3146597c5567bcdd5e1cc3bc929065ca37eb495ff
+DIST hypothesis-6.98.7.gh.tar.gz 9423646 BLAKE2B eb8869505917818f8ae1af14ade442678eb6a5424bf198a097757a3f22c0bb21aa4d9085c9fcddc2b11753e249f57892fd7ac2adf7b6cbd15bbce7e1bd836850 SHA512 2068ab1021c4bd030f6eb91a55c32c00da76e54dbdf5dbbc43fa28ac52120424a884b73add4bf2217fae60622713277b5f242ddd4dc63914b3417cd51ce158d5
diff --git a/dev-python/hypothesis/hypothesis-6.98.7.ebuild b/dev-python/hypothesis/hypothesis-6.98.7.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.98.7.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}