summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-08 08:15:53 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-08 08:33:18 +0200
commitd04659ca257a9688b3bdf8b634d6ad5858da14e8 (patch)
tree6c0c87c9f3a1243e8b0213bee50f3a9235606567 /dev-python/hypothesis
parentmedia-libs/libsidplayfp: bump to 2.2.2 (diff)
downloadgentoo-d04659ca257a9688b3bdf8b634d6ad5858da14e8.tar.gz
gentoo-d04659ca257a9688b3bdf8b634d6ad5858da14e8.tar.bz2
gentoo-d04659ca257a9688b3bdf8b634d6ad5858da14e8.zip
dev-python/hypothesis: Bump to 6.14.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypothesis')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.14.6.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 66063e034445..0cddb611f8c4 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-6.14.0.tar.gz 9135056 BLAKE2B 47d1efcee5e1c4037f1a20f08e3
DIST hypothesis-python-6.14.2.tar.gz 9135496 BLAKE2B f77f0668c4d0c2f5a952e06a40ae7898631804d3406c9711eb30a4e5a11e73ba2772be3cb437aacea2a75cd65f688a2485b98885c19cf743020900b0cf70f08c SHA512 e495e1c471fd4b185e23326700e85bf90635fcc8bf316c758c3285803ff0f7ad0269351b3a7631033495bb6498a8f19cb8661c55248ec5e14ff2a09e0c3af3c1
DIST hypothesis-python-6.14.3.tar.gz 9135537 BLAKE2B 2effb0c68cf3a7a2f7d56c0c46c2ba36cbed4fed35b8a617ec68a721990247370772b986f0492aab112f7420c07409f8d738485ca28f42e7aea919af52611b10 SHA512 1722c5dcf1eb7375fd09d4208851826582808449fcaaa0345f1461d9a531961500a9c888bec5a457efbbb34f8178464b3358a3187b94bb5c783af42b4e7287ce
DIST hypothesis-python-6.14.5.tar.gz 9135819 BLAKE2B 2e42949f81024038b901231a8446203388c8052ebaacf4a87d21356265fd1c09c9aa8b191dcd65780d45cc52ed9d48bb16440fc553addb4671e0ad901213ef64 SHA512 d047eea19129d5855bee5f012f5c91fe1f0de40228600fadad9c76709f951c003450f613f59848064b58f9d0e559b54b44744ae0aae689687488b6506cc8fe1a
+DIST hypothesis-python-6.14.6.tar.gz 9136187 BLAKE2B a9f0d24882266d5ccce0e940fb7e28ae654361215829ae87410ea18a0d304a78ecbfeaa8b74f7c415d60991e43f7b4beaaecbaaabbb697dac47aa360c5d59366 SHA512 fecf5af77d5f355861b6fbf3ea964a741b501a9db032c3f2ded2fb51605f2b961e2ad0633f671d6ffbc2e6ff4ca27412eb456ca7bd9a72a4a9e8b89cc79a7042
diff --git a/dev-python/hypothesis/hypothesis-6.14.6.ebuild b/dev-python/hypothesis/hypothesis-6.14.6.ebuild
new file mode 100644
index 000000000000..536affb7ae13
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.14.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!dev-python/pytest-describe
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}